summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorng0 <ng0@libertad.pw>2017-01-18 12:34:25 +0000
committerMarius Bakke <mbakke@fastmail.com>2017-01-18 20:24:18 +0100
commitcd4a232dd59af49a5e23eee3c723226455aabfad (patch)
treee4e03e13cf14908f125dd6cad1d917c2ca3953f3 /gnu
parentfdfb4b96044859198e0d16a05d42d4db08c02dd7 (diff)
downloadpatches-cd4a232dd59af49a5e23eee3c723226455aabfad.tar
patches-cd4a232dd59af49a5e23eee3c723226455aabfad.tar.gz
gnu: Add mcabber.
* gnu/packages/messaging.scm (mcabber): New variable. Co-authored-by: Marius Bakke <mbakke@fastmail.com>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/messaging.scm36
1 files changed, 36 insertions, 0 deletions
diff --git a/gnu/packages/messaging.scm b/gnu/packages/messaging.scm
index cded33a1ed..0c88059dca 100644
--- a/gnu/packages/messaging.scm
+++ b/gnu/packages/messaging.scm
@@ -37,6 +37,7 @@
#:use-module (guix build-system cmake)
#:use-module (gnu packages)
#:use-module (gnu packages aidc)
+ #:use-module (gnu packages aspell)
#:use-module (gnu packages autotools)
#:use-module (gnu packages avahi)
#:use-module (gnu packages base)
@@ -1152,4 +1153,39 @@ protocol allows.")
;; The files have LGPL2.0+ headers, but COPYING specifies LGPL2.1.
(license license:lgpl2.0+)))
+(define-public mcabber
+ (package
+ (name "mcabber")
+ (version "1.0.4")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "https://mcabber.com/files/"
+ name "-" version ".tar.bz2"))
+ (sha256
+ (base32
+ "02nfn5r7cjpnacym95l6bvczii232v3x2gi79gfa9syc7w0brdk3"))))
+ (build-system gnu-build-system)
+ (arguments
+ '(#:configure-flags (list "--enable-otr"
+ "--enable-aspell")))
+ (inputs
+ `(("gpgme" ,gpgme)
+ ("libotr" ,libotr)
+ ("aspell" ,aspell)
+ ("libidn" ,libidn)
+ ("glib" ,glib)
+ ("ncurses" ,ncurses)
+ ("loudmouth" ,loudmouth)))
+ (native-inputs
+ `(("pkg-config" ,pkg-config)))
+ (home-page "https://mcabber.com")
+ (description
+ "Mcabber is a small XMPP (Jabber) console client, which includes features
+such as SASL and TLS support, @dfn{Multi-User Chat} (MUC) support, logging,
+command-completion, OpenPGP encryption, @dfn{Off-the-Record Messaging} (OTR)
+support, and more.")
+ (synopsis "Small XMPP console client")
+ (license license:gpl2+)))
+
;;; messaging.scm ends here