summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2019-05-20 11:48:57 +0200
committerLudovic Courtès <ludo@gnu.org>2019-05-20 11:48:57 +0200
commit99f47b53f755f0a6cb15615c2b9a449a930e82e9 (patch)
tree853674ba28bc780e7916b2ccf044285d71c770b8 /gnu
parent8d036f3ecf3b837e8f38c2dca9f8a78568cc664b (diff)
parentfb2abbd6f5abac8ae0fec594594dd54ff7e3f4db (diff)
downloadpatches-99f47b53f755f0a6cb15615c2b9a449a930e82e9.tar
patches-99f47b53f755f0a6cb15615c2b9a449a930e82e9.tar.gz
Merge branch 'version-1.0.1'
Diffstat (limited to 'gnu')
-rw-r--r--gnu/installer/newt/partition.scm6
-rw-r--r--gnu/installer/parted.scm16
-rw-r--r--gnu/packages/javascript.scm6
-rw-r--r--gnu/packages/package-management.scm6
-rw-r--r--gnu/system/examples/vm-image.tmpl16
5 files changed, 30 insertions, 20 deletions
diff --git a/gnu/installer/newt/partition.scm b/gnu/installer/newt/partition.scm
index abc8bdcc03..cd9d46316a 100644
--- a/gnu/installer/newt/partition.scm
+++ b/gnu/installer/newt/partition.scm
@@ -751,12 +751,8 @@ by pressing the Exit button.~%~%")))
(disk (mklabel device label)))
(disk-commit disk)
disk)))
- (initial-partitions (disk-partitions disk))
(scheme (symbol-append method '- (run-scheme-page)))
- (user-partitions (append
- (auto-partition! disk #:scheme scheme)
- (create-special-user-partitions
- initial-partitions))))
+ (user-partitions (auto-partition! disk #:scheme scheme)))
(run-disk-page (list disk) user-partitions
#:guided? #t)))
((eq? method 'manual)
diff --git a/gnu/installer/parted.scm b/gnu/installer/parted.scm
index 4ccc0b1f51..bd2640d1ad 100644
--- a/gnu/installer/parted.scm
+++ b/gnu/installer/parted.scm
@@ -895,7 +895,10 @@ partitions (except the ESP on a GPT disk, if present) are wiped. SCHEME is the
desired partitioning scheme. It can be 'entire-root or
'entire-root-home. 'entire-root will create a swap partition and a root
partition occupying all the remaining space. 'entire-root-home will create a
-swap partition, a root partition and a home partition."
+swap partition, a root partition and a home partition.
+
+Return the complete list of partitions on DISK, including the ESP when it
+exists."
(let* ((device (disk-device disk))
(disk-type (disk-disk-type disk))
(has-extended? (disk-type-check-feature
@@ -1001,10 +1004,13 @@ swap partition, a root partition and a home partition."
(mount-point "/home")))))))
(new-partitions* (force-user-partitions-formatting
new-partitions)))
- (create-adjacent-partitions! disk
- new-partitions*
- #:last-partition-end
- (or end-esp-partition 0)))))
+ (append (if esp-partition
+ (list (partition->user-partition esp-partition))
+ '())
+ (create-adjacent-partitions! disk
+ new-partitions*
+ #:last-partition-end
+ (or end-esp-partition 0))))))
;;
diff --git a/gnu/packages/javascript.scm b/gnu/packages/javascript.scm
index 8731a44927..e7dcd7962d 100644
--- a/gnu/packages/javascript.scm
+++ b/gnu/packages/javascript.scm
@@ -117,7 +117,11 @@
(let ((minified (open-pipe* OPEN_READ "uglify-js" file)))
(call-with-output-file installed
(lambda (port)
- (dump-port minified port)))))
+ (dump-port minified port)))
+
+ (let ((exit (close-pipe minified)))
+ (unless (zero? exit)
+ (error "dear, uglify-js failed" exit)))))
(else
(install-file file (dirname installed))))))
(find-files "."))
diff --git a/gnu/packages/package-management.scm b/gnu/packages/package-management.scm
index b4e1e077fe..a356a6dab7 100644
--- a/gnu/packages/package-management.scm
+++ b/gnu/packages/package-management.scm
@@ -110,8 +110,8 @@
;; Latest version of Guix, which may or may not correspond to a release.
;; Note: the 'update-guix-package.scm' script expects this definition to
;; start precisely like this.
- (let ((version "1.0.0")
- (commit "326dcbf1b3c30aa525185fda435c34cb9495dd04")
+ (let ((version "1.0.1")
+ (commit "820429517f9cc8333704a839b4346ac4b02468c4")
(revision 1))
(package
(name "guix")
@@ -128,7 +128,7 @@
(commit commit)))
(sha256
(base32
- "0k9v9lh69q353x055id1sq1gx4p8idg8ifrgidv5s73wdil2cflm"))
+ "1vfp7ps1k1cwn8p0gsgarlxcy982hzyvb7zqnj66jqd258a1qfgh"))
(file-name (string-append "guix-" version "-checkout"))))
(build-system gnu-build-system)
(arguments
diff --git a/gnu/system/examples/vm-image.tmpl b/gnu/system/examples/vm-image.tmpl
index 0dbd31fe0a..7d984155bc 100644
--- a/gnu/system/examples/vm-image.tmpl
+++ b/gnu/system/examples/vm-image.tmpl
@@ -92,14 +92,18 @@ root ALL=(ALL) ALL
;; Use the DHCP client service rather than NetworkManager.
(service dhcp-client-service-type))
- ;; Remove GDM, NetworkManager, and wpa-supplicant, which don't make
- ;; sense in a VM.
+ ;; Remove GDM, ModemManager, NetworkManager, and wpa-supplicant,
+ ;; which don't make sense in a VM.
(remove (lambda (service)
(let ((type (service-kind service)))
- (memq type (list gdm-service-type
- wpa-supplicant-service-type
- cups-pk-helper-service-type
- network-manager-service-type))))
+ (or (memq type
+ (list gdm-service-type
+ wpa-supplicant-service-type
+ cups-pk-helper-service-type
+ network-manager-service-type
+ modem-manager-service-type))
+ (eq? 'network-manager-applet
+ (service-type-name type)))))
(modify-services %desktop-services
(login-service-type config =>
(login-configuration