summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorPierre Neidhardt <mail@ambrevar.xyz>2019-03-12 09:28:01 +0100
committerPierre Neidhardt <mail@ambrevar.xyz>2019-03-12 09:28:01 +0100
commit75dabac633bb9a33efbebf859f8aa4bb3b9582b2 (patch)
treed2377d9ce57dc141e376a80400811ca5929ad6bd /gnu
parentb6180f93bd256ec3e2b12c91ac7884f82313dd3b (diff)
downloadpatches-75dabac633bb9a33efbebf859f8aa4bb3b9582b2.tar
patches-75dabac633bb9a33efbebf859f8aa4bb3b9582b2.tar.gz
gnu: Add emacs-lisp-extra-font-lock.
* gnu/packages/emacs-xyz.scm (emacs-lisp-extra-font-lock): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/emacs-xyz.scm22
1 files changed, 22 insertions, 0 deletions
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index a82d6e9ea5..064b8cb054 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -13328,3 +13328,25 @@ completion systems for selecting commands, such as ido and ivy.")
dummy Latin text into a buffer. This can be useful if you need to produce
paragraphs or pages of text for testing purposes.")
(license license:gpl3+))))
+
+(define-public emacs-lisp-extra-font-lock
+ (let ((commit "4605eccbe1a7fcbd3cacf5b71249435413b4db4f"))
+ (package
+ (name "emacs-lisp-extra-font-lock")
+ (version (git-version "0.0.6" "1" commit))
+ (home-page "https://github.com/Lindydancer/lisp-extra-font-lock")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url home-page)
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "152vcp3mdlv33jf5va4rinl1d0k960gnfhbrqqrafazgx9j3ya8w"))))
+ (build-system emacs-build-system)
+ (synopsis "Highlight bound variables and quoted expressions in Emacs")
+ (description "This package highlight the location where local variables
+is created (bound, for example, by let) as well as quoted and backquoted
+constant expressions.")
+ (license license:gpl3+))))