summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2020-01-15 23:23:00 +0100
committerMarius Bakke <mbakke@fastmail.com>2020-01-24 20:44:33 +0100
commit5e7202bbdf407470bbb72cf0a74dea6961c2507a (patch)
treec85427e9d0c5cf2069fc1d7b1b99d10d34718fa8 /gnu
parent94fa51e17d23edbbdac2f66809b3c96315dd6781 (diff)
downloadpatches-5e7202bbdf407470bbb72cf0a74dea6961c2507a.tar
patches-5e7202bbdf407470bbb72cf0a74dea6961c2507a.tar.gz
gnu: python2-importlib-resources: Drop 'wheel' dependency.
* gnu/packages/python-xyz.scm (python2-importlib-resources)[native-inputs]: Remove. [arguments]: Add #:phases.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/python-xyz.scm14
1 files changed, 11 insertions, 3 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index d9b17fca32..e44696e454 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -4983,9 +4983,17 @@ older Python versions.")
"0y3hg12iby1qyaspnbisz4s4vxax7syikk3skznwqizqyv89y9yk"))))
(build-system python-build-system)
(arguments
- `(#:python ,python-2))
- (native-inputs
- `(("python-wheel" ,python2-wheel)))
+ `(#:python ,python-2
+ #:phases (modify-phases %standard-phases
+ ;; The build system tests for python-wheel, but it is
+ ;; not required for Guix nor the test suite. Just drop
+ ;; it to make bootstrapping pytest easier.
+ (add-after 'unpack 'drop-wheel-dependency
+ (lambda _
+ (substitute* "setup.cfg"
+ (("^[[:blank:]]+wheel")
+ ""))
+ #t)))))
(propagated-inputs
`(("python-pathlib2" ,python2-pathlib2)
("python-typing" ,python2-typing)))