summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorRyan Prior <rprior@protonmail.com>2020-05-01 14:47:20 -0500
committerTobias Geerinckx-Rice <me@tobias.gr>2020-05-15 20:37:42 +0200
commit5225626ffcdc29a62e8e089abcbb3d304febd2f2 (patch)
tree2128d5c7c2824b7e4e60b2246d7acd880ab62d8a /gnu
parent6e9ffc3f778b43aa42c2142ec9ebbe3be4bf47cc (diff)
downloadpatches-5225626ffcdc29a62e8e089abcbb3d304febd2f2.tar
patches-5225626ffcdc29a62e8e089abcbb3d304febd2f2.tar.gz
gnu: oil-shell: Rename to "oil".
* gnu/packages/shells.scm (oil): Rename variable from… (oil-shell): …this. Redefine using DEPRECATED-PACKAGE. Signed-off-by: Tobias Geerinckx-Rice <me@tobias.gr>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/shells.scm7
1 files changed, 5 insertions, 2 deletions
diff --git a/gnu/packages/shells.scm b/gnu/packages/shells.scm
index b752fb4a90..5c8c4b5d8a 100644
--- a/gnu/packages/shells.scm
+++ b/gnu/packages/shells.scm
@@ -780,9 +780,9 @@ Shell (pdksh).")
(license (list miros
isc)))) ; strlcpy.c
-(define-public oil-shell
+(define-public oil
(package
- (name "oil-shell")
+ (name "oil")
(version "0.7.0")
(source (origin
(method url-fetch)
@@ -826,6 +826,9 @@ is commonly written.")
(license (list psfl ; The Oil sources include a patched Python 2 source tree
asl2.0))))
+(define-public oil-shell
+ (deprecated-package "oil-shell" oil))
+
(define-public gash
(package
(name "gash")