summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorRicardo Wurmus <ricardo.wurmus@mdc-berlin.de>2015-12-23 17:34:07 +0100
committerRicardo Wurmus <ricardo.wurmus@mdc-berlin.de>2016-01-07 17:18:17 +0100
commitc63cef669991940108448d23c8b427898cf83547 (patch)
tree2e1e1630eb52a18eaf0725453cda13acd9f1b12a /gnu
parentfbf6045e33abe06c8190078d6691c3b97758fd6a (diff)
downloadpatches-c63cef669991940108448d23c8b427898cf83547.tar
patches-c63cef669991940108448d23c8b427898cf83547.tar.gz
gnu: Add BSgenome.
* gnu/packages/bioinformatics.scm (r-bsgenome): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/bioinformatics.scm30
1 files changed, 30 insertions, 0 deletions
diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index 31326f2752..8c2351da38 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -3836,6 +3836,36 @@ dependencies between GO terms can be implemented and applied.")
;; Any version of the LGPL applies.
(license license:lgpl2.1+)))
+(define-public r-bsgenome
+ (package
+ (name "r-bsgenome")
+ (version "1.38.0")
+ (source (origin
+ (method url-fetch)
+ (uri (bioconductor-uri "BSgenome" version))
+ (sha256
+ (base32
+ "130w0m6q8kkca7gyz1aqj5jjhalwvwi6rk2yvbjrnj4gpnncyrd2"))))
+ (properties
+ `((upstream-name . "BSgenome")))
+ (build-system r-build-system)
+ (propagated-inputs
+ `(("r-biocgenerics" ,r-biocgenerics)
+ ("r-biostrings" ,r-biostrings)
+ ("r-genomeinfodb" ,r-genomeinfodb)
+ ("r-genomicranges" ,r-genomicranges)
+ ("r-iranges" ,r-iranges)
+ ("r-rsamtools" ,r-rsamtools)
+ ("r-rtracklayer" ,r-rtracklayer)
+ ("r-s4vectors" ,r-s4vectors)
+ ("r-xvector" ,r-xvector)))
+ (home-page "http://bioconductor.org/packages/BSgenome")
+ (synopsis "Infrastructure for Biostrings-based genome data packages")
+ (description
+ "This package provides infrastructure shared by all Biostrings-based
+genome data packages and support for efficient SNP representation.")
+ (license license:artistic2.0)))
+
(define-public r-qtl
(package
(name "r-qtl")