summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorRicardo Wurmus <ricardo.wurmus@mdc-berlin.de>2015-12-18 14:08:17 +0100
committerRicardo Wurmus <ricardo.wurmus@mdc-berlin.de>2016-01-07 17:18:16 +0100
commit6e76dda2d08581d554b1605c819ec53958a4188f (patch)
tree69869188e647291d3038f2e60a4d28758b2935b9 /gnu
parentf8d74f70184b21b81b831f386f9a5f89a43a1d02 (diff)
downloadpatches-6e76dda2d08581d554b1605c819ec53958a4188f.tar
patches-6e76dda2d08581d554b1605c819ec53958a4188f.tar.gz
gnu: Add SummarizedExperiment.
* gnu/packages/bioinformatics.scm (r-summarizedexperiment): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/bioinformatics.scm29
1 files changed, 29 insertions, 0 deletions
diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index 51be381e93..4da9954c5b 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -3639,6 +3639,35 @@ binary variant call (BCF) and compressed indexed tab-delimited (tabix)
files.")
(license license:expat)))
+(define-public r-summarizedexperiment
+ (package
+ (name "r-summarizedexperiment")
+ (version "1.0.1")
+ (source (origin
+ (method url-fetch)
+ (uri (bioconductor-uri "SummarizedExperiment" version))
+ (sha256
+ (base32
+ "0w1dwp99p6i7sc3cn0ir3dr8ksgxwjf16675h5i8n6gbv4rl9lz6"))))
+ (properties
+ `((upstream-name . "SummarizedExperiment")))
+ (build-system r-build-system)
+ (propagated-inputs
+ `(("r-biobase" ,r-biobase)
+ ("r-biocgenerics" ,r-biocgenerics)
+ ("r-genomeinfodb" ,r-genomeinfodb)
+ ("r-genomicranges" ,r-genomicranges)
+ ("r-iranges" ,r-iranges)
+ ("r-s4vectors" ,r-s4vectors)))
+ (home-page "http://bioconductor.org/packages/SummarizedExperiment")
+ (synopsis "Container for representing genomic ranges by sample")
+ (description
+ "The SummarizedExperiment container contains one or more assays, each
+represented by a matrix-like object of numeric or other mode. The rows
+typically represent genomic ranges of interest and the columns represent
+samples.")
+ (license license:artistic2.0)))
+
(define-public r-qtl
(package
(name "r-qtl")