summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorClément Lassieur <clement@lassieur.org>2019-02-02 11:00:49 +0100
committerClément Lassieur <clement@lassieur.org>2019-02-02 11:14:39 +0100
commitba25ba903d72ffb287846bea4e151dbc21d2f45d (patch)
treeb002d67f64ff50c9ec7bc6b75a0d2b3bcbb95d01 /gnu
parent43af5f9d1961a89430d19a2e1509615586bc5dbd (diff)
downloadpatches-ba25ba903d72ffb287846bea4e151dbc21d2f45d.tar
patches-ba25ba903d72ffb287846bea4e151dbc21d2f45d.tar.gz
gnu: Add emacs-dtrt-indent.
* gnu/packages/emacs-xyz.scm (emacs-dtrt-indent): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/emacs-xyz.scm22
1 files changed, 22 insertions, 0 deletions
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 163fe93543..785bb84d88 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -12992,3 +12992,25 @@ front end to mpc, a client for the @dfn{Music Player Daemon} (MPD).")
mode for editing gnuplot scripts. It provides syntax highlighting,
indentation and a command to plot the file.")
(license license:gpl3+)))
+
+(define-public emacs-dtrt-indent
+ (package
+ (name "emacs-dtrt-indent")
+ (version "0.8")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/jscheid/dtrt-indent")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "0pgf0pvqd8k4yzhdn2df9lp0y8hmlm2ccrh07jivwlccs95pcz7z"))))
+ (build-system emacs-build-system)
+ (home-page "https://github.com/jscheid/dtrt-indent")
+ (synopsis "Minor mode that guesses the indentation offset")
+ (description "This package provides a minor mode that guesses the
+indentation offset originally used for creating source code files and
+transparently adjusts the corresponding settings in Emacs, making it more
+convenient to edit foreign files.")
+ (license license:gpl2+)))