summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorCarlo Zancanaro <carlo@zancanaro.id.au>2017-01-22 13:35:55 +0800
committer宋文武 <iyzsong@member.fsf.org>2017-01-22 13:40:48 +0800
commitaf7caada4022974dbf5bdf64ede337cfdc5dc932 (patch)
tree168cb1a28c468a5963a81ea07d9117d1707e66ae /gnu
parentcba84a38054b6ff3fd88a670a8d0a591e12d24db (diff)
downloadpatches-af7caada4022974dbf5bdf64ede337cfdc5dc932.tar
patches-af7caada4022974dbf5bdf64ede337cfdc5dc932.tar.gz
gnu: Add python2-slowaes.
* gnu/packages/python.scm (python2-slowaes): New variable. Signed-off-by: 宋文武 <iyzsong@member.fsf.org>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/python.scm21
1 files changed, 21 insertions, 0 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index d26053b224..5feca2b68e 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -12522,3 +12522,24 @@ console.")
(define-public python2-qrcode
(package-with-python2 python-qrcode))
+
+;; SlowAES isn't compatible with Python 3.
+(define-public python2-slowaes
+ (package
+ (name "python2-slowaes")
+ (version "0.1a1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "slowaes" version))
+ (sha256
+ (base32
+ "02dzajm83a7lqgxf6r3hgj64wfmcxz8gs4nvgxpvj5n19kjqlrc3"))))
+ (build-system python-build-system)
+ (arguments `(#:python ,python-2))
+ (home-page "http://code.google.com/p/slowaes/")
+ (synopsis "Implementation of AES in Python")
+ (description "This package contains an implementation of AES in Python.
+This implementation is slow (hence the project name) but still useful when
+faster ones are not available.")
+ (license license:asl2.0)))