summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2017-01-08 23:16:51 +0100
committerLudovic Courtès <ludo@gnu.org>2017-01-08 23:26:47 +0100
commit9e3e972d1eed2198b8b147b4326cf022eb4d4a7f (patch)
tree6a6f87149dbcd744bda280a46bc41975e4b6130b /gnu
parentdfb01baec4a68833539b3f1ff4f4fb53a367cdcb (diff)
downloadpatches-9e3e972d1eed2198b8b147b4326cf022eb4d4a7f.tar
patches-9e3e972d1eed2198b8b147b4326cf022eb4d4a7f.tar.gz
gnu: Add fprintd.
* gnu/packages/freedesktop.scm (fprintd): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/freedesktop.scm30
1 files changed, 30 insertions, 0 deletions
diff --git a/gnu/packages/freedesktop.scm b/gnu/packages/freedesktop.scm
index 4f00826d77..9cfb987976 100644
--- a/gnu/packages/freedesktop.scm
+++ b/gnu/packages/freedesktop.scm
@@ -839,3 +839,33 @@ wish to perform colour calibration.")
developers to add support for consumer fingerprint readers to their
software.")
(license license:lgpl2.1+)))
+
+(define-public fprintd
+ (package
+ (name "fprintd")
+ (version "0.7.0")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append
+ "https://people.freedesktop.org/~hadess/fprintd-"
+ version ".tar.xz"))
+ (sha256
+ (base32
+ "05915i0bv7q62fqrs5diqwr8dz3pwqa1c1ivcgggkjyw0xk4ldp5"))))
+ (build-system gnu-build-system)
+ (native-inputs
+ `(("pkg-config" ,pkg-config)
+ ("intltool" ,intltool)))
+ (inputs
+ `(("libfprint" ,libfprint)
+ ("dbus-glib" ,dbus-glib)
+ ("polkit" ,polkit)
+ ("linux-pam" ,linux-pam))) ;for pam_fprintd
+ (home-page "https://www.freedesktop.org/wiki/Software/fprint/fprintd/")
+ (synopsis "D-Bus daemon that exposes fingerprint reader functionality")
+ (description
+ "fprintd is a D-Bus daemon that offers functionality of libfprint, a
+library to access fingerprint readers, over the D-Bus interprocess
+communication bus. This daemon layer above libfprint solves problems related
+to applications simultaneously competing for fingerprint readers.")
+ (license license:gpl2+)))