summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2017-01-21 22:57:12 +0100
committerRicardo Wurmus <rekado@elephly.net>2017-01-22 10:16:28 +0100
commit79f3e82bdce9f3e4feeeeee75f40d24cad6e4b2b (patch)
treefa96a19ed67f163ccfc7af39a7fb7a8528fc3068 /gnu
parentdf05d80ad09986a6e536144573179ba5a5b649a5 (diff)
downloadpatches-79f3e82bdce9f3e4feeeeee75f40d24cad6e4b2b.tar
patches-79f3e82bdce9f3e4feeeeee75f40d24cad6e4b2b.tar.gz
gnu: fish: Embed full path to Python.
Fixes <https://bugs.gnu.org/25467>. * gnu/packages/shells.scm (fish)[arguments]: Rename phase "patch-bc" to "embed-store-paths"; embed full path to Python.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/shells.scm10
1 files changed, 7 insertions, 3 deletions
diff --git a/gnu/packages/shells.scm b/gnu/packages/shells.scm
index 5237e81206..16c76ef661 100644
--- a/gnu/packages/shells.scm
+++ b/gnu/packages/shells.scm
@@ -5,6 +5,7 @@
;;; Copyright © 2015 Jeff Mickey <j@codemac.net>
;;; Copyright © 2016 Tobias Geerinckx-Rice <me@tobias.gr>
;;; Copyright © 2016 Stefan Reichör <stefan@xsteve.at>
+;;; Copyright © 2017 Ricardo Wurmus <rekado@elephly.net>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -106,14 +107,17 @@ direct descendant of NetBSD's Almquist Shell (@command{ash}).")
#:configure-flags '("--sysconfdir=/etc")
#:phases
(modify-phases %standard-phases
- ;; Replace 'bc' by its absolute file name in the store.
- (add-after 'unpack 'patch-bc
+ ;; Embed absolute paths to store items.
+ (add-after 'unpack 'embed-store-paths
(lambda* (#:key inputs outputs #:allow-other-keys)
(substitute* '("share/functions/math.fish"
"share/functions/seq.fish")
(("\\| bc")
(string-append "| " (assoc-ref %build-inputs "bc")
- "/bin/bc"))))))))
+ "/bin/bc")))
+ (substitute* "share/functions/fish_update_completions.fish"
+ (("python") (which "python")))
+ #t)))))
(synopsis "The friendly interactive shell")
(description
"Fish (friendly interactive shell) is a shell focused on interactive use,