summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorTimothy Sample <samplet@ngyro.com>2019-11-03 12:22:18 -0500
committerTimothy Sample <samplet@ngyro.com>2019-11-20 20:48:19 -0500
commit4a0ffae5900bb542017f244c11b7874612714360 (patch)
tree92315d2d62f45120a39051a797a007eabd200e2f /gnu
parent93c1fdd3032446f3933fba5c6bae367a191dd1d4 (diff)
downloadpatches-4a0ffae5900bb542017f244c11b7874612714360.tar
patches-4a0ffae5900bb542017f244c11b7874612714360.tar.gz
gnu: ghc-fgl-arbitrary: Update dependency constraints.
* gnu/packages/haskell-xyz.scm (ghc-fgl-arbitrary): Change the phase that updates the Cabal file to allow for newer versions of 'hspec' and 'QuickCheck'.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/haskell-xyz.scm4
1 files changed, 2 insertions, 2 deletions
diff --git a/gnu/packages/haskell-xyz.scm b/gnu/packages/haskell-xyz.scm
index e6c3275f86..6a5f26b8ab 100644
--- a/gnu/packages/haskell-xyz.scm
+++ b/gnu/packages/haskell-xyz.scm
@@ -3482,9 +3482,9 @@ encourages inductive, recursive definitions of graph algorithms.")
(lambda _
(substitute* "fgl-arbitrary.cabal"
(("QuickCheck >= 2\\.3 && < 2\\.10")
- "QuickCheck >= 2.3 && < 2.12")
+ "QuickCheck >= 2.3 && < 2.14")
(("hspec >= 2\\.1 && < 2\\.5")
- "hspec >= 2.1 && < 2.6")))))))
+ "hspec >= 2.1 && < 2.8")))))))
(inputs
`(("ghc-fgl" ,ghc-fgl)
("ghc-quickcheck" ,ghc-quickcheck)