summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2019-10-02 12:07:46 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2019-10-02 12:16:41 +0200
commite8ded3ee6af0324fbca067511768be1c3bd1ad66 (patch)
tree51edf375abcbb715dccc6f96d180d1260628c712 /gnu
parentd8de38563b7a32a96873a8dbc918b6448f3d8665 (diff)
downloadpatches-e8ded3ee6af0324fbca067511768be1c3bd1ad66.tar
patches-e8ded3ee6af0324fbca067511768be1c3bd1ad66.tar.gz
gnu: linux-libre-headers@5.3: Install.
Upstream has separated building and installing the UAPI headers, and now requires rsync for the latter. Follow-up to commit 9e34a5f3b2d37cc8fb9f16620747df41488665be. * gnuk/packages/linux.scm (make-linux-libre-headers*)[native-inputs]: Add rsync for version 5.3 and higher.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/linux.scm4
1 files changed, 4 insertions, 0 deletions
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index e333135a0f..679d0b00c7 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -116,6 +116,7 @@
#:use-module (gnu packages xdisorg)
#:use-module (gnu packages xorg)
#:use-module (gnu packages groff)
+ #:use-module (gnu packages rsync)
#:use-module (gnu packages selinux)
#:use-module (gnu packages swig)
#:use-module (guix build-system cmake)
@@ -482,6 +483,9 @@ corresponding UPSTREAM-SOURCE (an origin), using the given DEBLOB-SCRIPTS."
,@(if (version>=? version "4.16")
`(("flex" ,flex)
("bison" ,bison))
+ '())
+ ,@(if (version>=? version "5.3")
+ `(("rsync" ,rsync))
'())))
(arguments
`(#:modules ((guix build gnu-build-system)