summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorPierre Neidhardt <mail@ambrevar.xyz>2020-01-03 16:44:34 +0100
committerPierre Neidhardt <mail@ambrevar.xyz>2020-01-03 16:46:41 +0100
commitcbda07d4fc1e17348a6976422edbc3c44367a3d4 (patch)
tree52fa6f0ad14a36f172368e7e46278daa2b5dd3f9 /gnu
parentf5b1da68c82c177da7696343d13de8bf92365ef1 (diff)
downloadpatches-cbda07d4fc1e17348a6976422edbc3c44367a3d4.tar
patches-cbda07d4fc1e17348a6976422edbc3c44367a3d4.tar.gz
gnu: Add plump.
* gnu/packages/lisp-xyz.scm (cl-plump, sbcl-plump): New variables.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/lisp-xyz.scm35
1 files changed, 35 insertions, 0 deletions
diff --git a/gnu/packages/lisp-xyz.scm b/gnu/packages/lisp-xyz.scm
index 764d34e7a6..0aa7a21ec5 100644
--- a/gnu/packages/lisp-xyz.scm
+++ b/gnu/packages/lisp-xyz.scm
@@ -7404,3 +7404,38 @@ functions for arrays and vectors. Originally from Plump.")
(define-public cl-array-utils
(sbcl-package->cl-source-package sbcl-array-utils))
+
+(define-public sbcl-plump
+ (let ((commit "16f1231bf706cfbc54d9e55a853ca945e4452a08")
+ (revision "0"))
+ (package
+ (name "sbcl-plump")
+ (version (git-version "2.0.0" revision commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri
+ (git-reference
+ (url "https://github.com/Shinmera/plump")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "0705k8pbip51v74rccgwscwph439f2pma9f915qf1h4bhjx999ip"))))
+ (build-system asdf-build-system/sbcl)
+ (inputs
+ `(("array-utils" ,sbcl-array-utils)
+ ("documentation-utils" ,sbcl-documentation-utils)))
+ (synopsis "Lenient XML / XHTML / HTML parser for Common Lisp")
+ (description
+ "Plump is a parser for HTML/XML-like documents, focusing on being
+lenient towards invalid markup. It can handle things like invalid attributes,
+bad closing tag order, unencoded entities, inexistent tag types, self-closing
+tags and so on. It parses documents to a class representation and offers a
+small set of DOM functions to manipulate it. It can be extended to parse to
+your own classes.")
+ (home-page "https://shinmera.github.io/plump/")
+ (license license:zlib))))
+
+(define-public cl-plump
+ (sbcl-package->cl-source-package sbcl-plump))