summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorHartmut Goebel <h.goebel@crazy-compilers.com>2016-10-16 19:19:33 +0200
committerHartmut Goebel <h.goebel@crazy-compilers.com>2016-11-15 22:31:34 +0100
commit130fe99410e52eb647c8fcff8e2de1c6b0b7575a (patch)
treea4712154d190bd0e306fa338349463593c141abe /gnu
parentf78e1c27ef8b3ea82c38c689f6b2b819c47aa6e6 (diff)
downloadpatches-130fe99410e52eb647c8fcff8e2de1c6b0b7575a.tar
patches-130fe99410e52eb647c8fcff8e2de1c6b0b7575a.tar.gz
gnu: python-pyjwt: Add missing inputs and enable test-suite.
* gnu/packages/python.scm (python-pyjwt) [native-inputs]: Add python-pytest and python-pytest-cov. [arguments]. Remove.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/python.scm6
1 files changed, 3 insertions, 3 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index a14c15776f..8213e83fb1 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -2440,9 +2440,9 @@ somewhat intelligeble.")
"1556v2jppd8mjkkj66pxb5rcazm35jq81r233mdl8hfmz9n3icp1"))))
(build-system python-build-system)
(native-inputs
- `(("python-pytest-runner" ,python-pytest-runner)))
- (arguments
- '(#:tests? #f)) ; test suite doesn't work
+ `(("python-pytest" ,python-pytest)
+ ("python-pytest-cov" ,python-pytest-cov)
+ ("python-pytest-runner" ,python-pytest-runner)))
(home-page "http://github.com/progrium/pyjwt")
(synopsis "JSON Web Token implementation in Python")
(description