summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2015-01-16 15:47:03 +0100
committerLudovic Courtès <ludo@gnu.org>2015-01-16 21:11:55 +0100
commitf327b36edb1f754ddf5057959eaa26679e808687 (patch)
tree22f62a37e77dccbc88e6852f235fa90d9561e1f7 /gnu
parent24004073f06ed0e79c39c5deed9f859e0fb7971e (diff)
downloadpatches-f327b36edb1f754ddf5057959eaa26679e808687.tar
patches-f327b36edb1f754ddf5057959eaa26679e808687.tar.gz
gnu: Add CGAL.
* gnu/packages/graphics.scm: New file. * gnu-system.am (GNU_SYSTEM_MODULES): Add it.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/graphics.scm65
1 files changed, 65 insertions, 0 deletions
diff --git a/gnu/packages/graphics.scm b/gnu/packages/graphics.scm
new file mode 100644
index 0000000000..55d2a198eb
--- /dev/null
+++ b/gnu/packages/graphics.scm
@@ -0,0 +1,65 @@
+;;; GNU Guix --- Functional package management for GNU
+;;; Copyright © 2015 Ludovic Courtès <ludo@gnu.org>
+;;;
+;;; This file is part of GNU Guix.
+;;;
+;;; GNU Guix is free software; you can redistribute it and/or modify it
+;;; under the terms of the GNU General Public License as published by
+;;; the Free Software Foundation; either version 3 of the License, or (at
+;;; your option) any later version.
+;;;
+;;; GNU Guix is distributed in the hope that it will be useful, but
+;;; WITHOUT ANY WARRANTY; without even the implied warranty of
+;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+;;; GNU General Public License for more details.
+;;;
+;;; You should have received a copy of the GNU General Public License
+;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
+
+(define-module (gnu packages graphics)
+ #:use-module (guix download)
+ #:use-module (guix packages)
+ #:use-module (guix build-system gnu)
+ #:use-module (guix build-system cmake)
+ #:use-module ((guix licenses) #:prefix license:)
+ #:use-module (gnu packages multiprecision)
+ #:use-module (gnu packages boost))
+
+(define-public cgal
+ (package
+ (name "cgal")
+ (version "4.5.1")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append
+ "http://gforge.inria.fr/frs/download.php/file/34402/CGAL-"
+ version ".tar.xz"))
+ (sha256
+ (base32
+ "1565ycbds92bxmhi09avc1jl6ks141ig00j110l49gqxp9swy6zv"))))
+ (build-system cmake-build-system)
+ (arguments
+ '(;; "RelWithDebInfo" is not supported.
+ #:build-type "Release"
+
+ ;; No 'test' target.
+ #:tests? #f))
+ (inputs
+ `(("mpfr" ,mpfr)
+ ("gmp" ,gmp)
+ ("boost" ,boost)))
+ (home-page "http://cgal.org/")
+ (synopsis "Computational geometry algorithms library")
+ (description
+ "CGAL provides easy access to efficient and reliable geometric algorithms
+in the form of a C++ library. CGAL is used in various areas needing geometric
+computation, such as: computer graphics, scientific visualization, computer
+aided design and modeling, geographic information systems, molecular biology,
+medical imaging, robotics and motion planning, mesh generation, numerical
+methods, etc. It provides data structures and algorithms such as
+triangulations, Voronoi diagrams, polygons, polyhedra, mesh generation, and
+many more.")
+
+ ;; The 'LICENSE' file explains that a subset is available under more
+ ;; permissive licenses.
+ (license license:gpl3+)))