summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorBen Woodcroft <donttrustben@gmail.com>2015-06-27 22:28:19 +1000
committerMark H Weaver <mhw@netris.org>2015-07-05 02:56:53 -0400
commitaf86047537737991f33885c1e0afdb48547132f9 (patch)
tree07ab012abd3f7fa10d4a4a849074f23d7cde9da6 /gnu
parent151714ca8c39e5de10dd212f5e360cea06c51604 (diff)
downloadpatches-af86047537737991f33885c1e0afdb48547132f9.tar
patches-af86047537737991f33885c1e0afdb48547132f9.tar.gz
gnu: Add prodigal.
* gnu/packages/bioinformatics.scm (prodigal): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/bioinformatics.scm31
1 files changed, 31 insertions, 0 deletions
diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index 6a3376d395..2ad77acd04 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -1600,6 +1600,37 @@ the phenotype as it models the data.")
generated using the PacBio Iso-Seq protocol.")
(license license:bsd-3))))
+(define-public prodigal
+ (package
+ (name "prodigal")
+ (version "2.6.2")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append
+ "https://github.com/hyattpd/Prodigal/archive/v"
+ version ".tar.gz"))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32
+ "0m8sb0fg6lmxrlpzna0am6svbnlmd3dckrhgzxxgb3gxr5fyj284"))))
+ (build-system gnu-build-system)
+ (arguments
+ `(#:tests? #f ;no check target
+ #:make-flags (list (string-append "INSTALLDIR="
+ (assoc-ref %outputs "out")
+ "/bin"))
+ #:phases
+ (modify-phases %standard-phases
+ (delete 'configure))))
+ (home-page "http://prodigal.ornl.gov")
+ (synopsis "Protein-coding gene prediction for Archaea and Bacteria")
+ (description
+ "Prodigal runs smoothly on finished genomes, draft genomes, and
+metagenomes, providing gene predictions in GFF3, Genbank, or Sequin table
+format. It runs quickly, in an unsupervised fashion, handles gaps, handles
+partial genes, and identifies translation initiation sites.")
+ (license license:gpl3+)))
+
(define-public rsem
(package
(name "rsem")