summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2020-04-11 15:34:52 +0200
committerMarius Bakke <mbakke@fastmail.com>2020-04-11 15:34:52 +0200
commit72cf14948dd2f9ef049479bdb1321e2568e10ac5 (patch)
tree3ecb8e78beab06618217c9551a6937071eed0f1d /gnu
parente66d5d6e29f09cd51ed6284e0f927c341f4b88c9 (diff)
downloadpatches-72cf14948dd2f9ef049479bdb1321e2568e10ac5.tar
patches-72cf14948dd2f9ef049479bdb1321e2568e10ac5.tar.gz
gnu: python-gevent: Update to 1.5.0.
* gnu/packages/python-xyz.scm (python-gevent): Update to 1.5.0. [arguments]: Split the unbundling and include path adjustments intwo two phases. Enable previously failing test; disable two others. Use a format string instead of DISPLAY when writing skipped_tests.txt.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/python-xyz.scm18
1 files changed, 10 insertions, 8 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index e9284d9342..25b0ae39a2 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -11047,13 +11047,13 @@ graphviz.")
(define-public python-gevent
(package
(name "python-gevent")
- (version "1.4.0")
+ (version "1.5.0")
(source (origin
(method url-fetch)
(uri (pypi-uri "gevent" version))
(sha256
(base32
- "1lchr4akw2jkm5v4kz7bdm4wv3knkfhbfn9vkkz4s5yrkcxzmdqy"))
+ "0aac3d4vhv5n4rsb6cqzq0d1xx9immqz4fmpddw35yxkwdc450dj"))
(modules '((guix build utils)))
(snippet
'(begin
@@ -11079,14 +11079,16 @@ graphviz.")
(find-files "src/greentest" "\\.py$"))
#t))
(add-before 'build 'do-not-use-bundled-sources
- (lambda* (#:key inputs #:allow-other-keys)
+ (lambda _
(setenv "GEVENTSETUP_EMBED" "0")
;; Prevent building bundled libev.
(substitute* "setup.py"
(("run_make=_BUILDING")
"run_make=False"))
-
+ #t))
+ (add-before 'build 'add-greenlet-on-C_INCLUDE_PATH
+ (lambda* (#:key inputs #:allow-other-keys)
(let ((greenlet (string-append
(assoc-ref inputs "python-greenlet")
"/include")))
@@ -11137,9 +11139,6 @@ graphviz.")
"test_thread.py"
"test_threading.py"
"test__threading_2.py"
- ;; FIXME: test_patch_twice_warning_events fails for
- ;; no apparent reason. Needs more investigation!
- "test__monkey.py"
;; These tests rely on KeyboardInterrupts which do not
;; work inside the build container for some reason
;; (lack of controlling terminal?).
@@ -11147,12 +11146,15 @@ graphviz.")
"test__issues461_471.py"
;; TODO: Patch out the tests that use getprotobyname, etc
;; instead of disabling all the tests from these files.
+ "test__resolver_dnspython.py"
+ "test__doctests.py"
"test__all__.py"
"test___config.py"
"test__execmodules.py")))
(call-with-output-file "skipped_tests.txt"
(lambda (port)
- (display (string-join disabled-tests "\n") port)))
+ (format port "~a~%"
+ (string-join disabled-tests "\n"))))
#t)))
(replace 'check
(lambda _