summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorJulien Lepiller <julien@lepiller.eu>2020-05-16 15:16:52 +0200
committerJulien Lepiller <julien@lepiller.eu>2020-05-16 17:43:25 +0200
commit523cbfbd55fa73d0c31e2ac84008a18fffbd42f5 (patch)
treee59bde2a31075c3afd385d94dde27cb137ea5743 /gnu
parenta3dfe052850257de0a64bec6797f803145903179 (diff)
downloadpatches-523cbfbd55fa73d0c31e2ac84008a18fffbd42f5.tar
patches-523cbfbd55fa73d0c31e2ac84008a18fffbd42f5.tar.gz
gnu: bap: Update to 2.0.0.
* gnu/packages/ocaml.scm (bap): Update to 2.0.0.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/ocaml.scm15
1 files changed, 11 insertions, 4 deletions
diff --git a/gnu/packages/ocaml.scm b/gnu/packages/ocaml.scm
index c5ec3174ed..916c7fe292 100644
--- a/gnu/packages/ocaml.scm
+++ b/gnu/packages/ocaml.scm
@@ -2975,7 +2975,7 @@ XML and Protocol Buffers formats.")
(define-public bap
(package
(name "bap")
- (version "1.6.0")
+ (version "2.0.0")
(home-page "https://github.com/BinaryAnalysisPlatform/bap")
(source (origin
(method git-fetch)
@@ -2985,7 +2985,7 @@ XML and Protocol Buffers formats.")
(file-name (git-file-name name version))
(sha256
(base32
- "0ryf2xb37pj2f9mc3p5prqgqrylph9qgq7q9jnbx8b03nzzpa6h6"))))
+ "0lb9xkfp67wjjqr75p6krivmjra7l5673236v9ny4gp0xi0755bk"))))
(build-system ocaml-build-system)
(native-inputs
`(("ocaml-oasis" ,(package-with-ocaml4.07 ocaml-oasis))
@@ -3003,16 +3003,23 @@ XML and Protocol Buffers formats.")
("ocaml-ocurl" ,(package-with-ocaml4.07 ocaml-ocurl))
("ocaml-piqi" ,ocaml4.07-piqi)
("ocaml-ppx-jane" ,ocaml4.07-ppx-jane)
+ ("ocaml-utop" ,ocaml4.07-utop)
("ocaml-uuidm" ,(package-with-ocaml4.07 ocaml-uuidm))
("ocaml-uri" ,ocaml4.07-uri)
("ocaml-zarith" ,(package-with-ocaml4.07 ocaml-zarith))))
(inputs
- `(("llvm" ,llvm-3.8)
- ("gmp" ,gmp)))
+ `(("gmp" ,gmp)
+ ("llvm" ,llvm-3.8)
+ ("ncurses" ,ncurses)))
(arguments
`(#:use-make? #t
#:phases
(modify-phases %standard-phases
+ (add-before 'configure 'fix-ncurses
+ (lambda _
+ (substitute* "oasis/llvm"
+ (("-lcurses") "-lncurses"))
+ #t))
(replace 'configure
(lambda* (#:key outputs inputs #:allow-other-keys)
;; add write for user, to prevent a failure in the install phase