summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2014-12-27 23:54:23 +0100
committerLudovic Courtès <ludo@gnu.org>2014-12-27 23:54:23 +0100
commit2a8d44015ff2672b7a9a2ea5054b51a83b0e934b (patch)
tree00cdf5dac6acd2bd736a726bc5e032f328d29d6a /gnu
parentcc9a5c1454f49850c078045c88a300c1195eabc8 (diff)
downloadpatches-2a8d44015ff2672b7a9a2ea5054b51a83b0e934b.tar
patches-2a8d44015ff2672b7a9a2ea5054b51a83b0e934b.tar.gz
gnu: libxml2: Add search path specification.
* gnu/packages/xml.scm (libxml2)[native-search-paths, search-paths]: New fields. * gnu/packages/gnome.scm (gnome-doc-utils)[arguments]: Remove. * gnu/packages/gps.scm (gpscorrelate)[arguments]: Remove settings for 'XML_CATALOG_FILES' from 'configure' phase. * gnu/packages/web.scm (tinyproxy)[arguments]: Likewise.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/gnome.scm11
-rw-r--r--gnu/packages/gps.scm12
-rw-r--r--gnu/packages/web.scm11
-rw-r--r--gnu/packages/xml.scm12
4 files changed, 14 insertions, 32 deletions
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index d9a22b41bb..daa172fe2a 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -143,17 +143,6 @@ The gnome-about program helps find which version of GNOME is installed.")
(base32
"19n4x25ndzngaciiyd8dd6s2mf9gv6nv3wv27ggns2smm7zkj1nb"))))
(build-system gnu-build-system)
- (arguments
- `(#:phases
- (alist-cons-before
- 'check 'pre-check
- (lambda* (#:key inputs #:allow-other-keys #:rest args)
- ;; This is needed, because without it, xmlint etc tries
- ;; to download docbookx.dtd from the net
- (setenv "XML_CATALOG_FILES"
- (string-append (assoc-ref inputs "docbook-xml")
- "/xml/dtd/docbook/catalog.xml")))
- %standard-phases)))
(native-inputs
`(("intltool" ,intltool)
("docbook-xml" ,docbook-xml-4.4)
diff --git a/gnu/packages/gps.scm b/gnu/packages/gps.scm
index 1fbf38f125..231b1d1b04 100644
--- a/gnu/packages/gps.scm
+++ b/gnu/packages/gps.scm
@@ -100,17 +100,7 @@ manipulate maps.")
(substitute* "Makefile"
(("prefix[[:blank:]]*=.*$")
(string-append "prefix = " (assoc-ref outputs "out")
- "\n")))
-
- ;; Make sure the DocBook XML and XSL files are found.
- ;; Note: this is a space-separated list.
- (setenv "XML_CATALOG_FILES"
- (string-append (assoc-ref inputs "docbook-xml")
- "/xml/dtd/docbook/catalog.xml "
- (assoc-ref inputs "docbook-xsl")
- "/xml/xsl/"
- ,(package-full-name docbook-xsl)
- "/catalog.xml")))
+ "\n"))))
%standard-phases)
#:tests? #f))
(inputs
diff --git a/gnu/packages/web.scm b/gnu/packages/web.scm
index 1ff3dfb5a5..8a64211697 100644
--- a/gnu/packages/web.scm
+++ b/gnu/packages/web.scm
@@ -644,16 +644,7 @@ help you implement simple HTTP servers.")
;; Uncommenting the next two lines may assist in debugging
;; (substitute* "docs/man5/Makefile" (("a2x") "a2x -v"))
;; (setenv "XML_DEBUG_CATALOG" "1")
-
- (setenv "XML_CATALOG_FILES"
- (string-append
- (assoc-ref inputs "docbook-xsl")
- "/xml/xsl/docbook-xsl-1.78.1/catalog.xml"
- ;; Contrary to the documentation, the file names must
- ;; be separated by a space, not a colon.
- " "
- (assoc-ref inputs "docbook-xml")
- "/xml/dtd/docbook/catalog.xml")))
+ #t)
%standard-phases)))
;; All of the below are used to generate the documentation
;; (Should they be propagated inputs of asciidoc ??)
diff --git a/gnu/packages/xml.scm b/gnu/packages/xml.scm
index 63d0ef2132..62f8c3c376 100644
--- a/gnu/packages/xml.scm
+++ b/gnu/packages/xml.scm
@@ -68,6 +68,18 @@ things the parser might find in the XML document (like start tags).")
(inputs `(("zlib" ,zlib)))
(native-inputs `(("perl" ,perl)
("python" ,python-2))) ; incompatible with Python 3 (print syntax)
+
+
+ ;; $XML_CATALOG_FILES lists 'catalog.xml' files found in under the 'xml'
+ ;; sub-directory of any given package.
+ (native-search-paths (search-path-specification
+ (variable "XML_CATALOG_FILES")
+ (separator " ")
+ (files '("xml"))
+ (file-pattern "^catalog\\.xml$")
+ (file-type 'regular)))
+ (search-paths native-search-paths)
+
(arguments
`(#:phases
(alist-replace