summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2020-04-08 14:33:43 +0200
committerMarius Bakke <mbakke@fastmail.com>2020-04-08 14:33:43 +0200
commit155aaca7febe58b59a55c5d4cd5bc5abcbe66d39 (patch)
treea05e670d74a5377f5a4c731a8f791ea84d6c514d /gnu
parent76125bc061b199936c60c348290a593ac3450945 (diff)
downloadpatches-155aaca7febe58b59a55c5d4cd5bc5abcbe66d39.tar
patches-155aaca7febe58b59a55c5d4cd5bc5abcbe66d39.tar.gz
gnu: python-pyjwt: Remove dependency on old version of 'pytest-runner'.
* gnu/packages/python-xyz.scm (python-pyjwt)[arguments]: New field. [native-inputs]: Remove PYTHON-PYTEST-RUNNER.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/python-xyz.scm14
1 files changed, 12 insertions, 2 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 9703301da0..5e56a2b29c 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -2659,10 +2659,20 @@ memory usage and transliteration quality.")
(find-files "." "\\.pyc$"))
#t))))
(build-system python-build-system)
+ (arguments
+ '(#:phases (modify-phases %standard-phases
+ (replace 'check
+ (lambda _
+ ;; Mimic upstream commit 3a20892442b34c7 to get
+ ;; rid of dependency on pytest-runner < 5.0.
+ ;; Remove substitution for PyJWT > 1.7.1.
+ (substitute* "setup.py"
+ ((".*pytest-runner.*")
+ ""))
+ (invoke "pytest" "-vv"))))))
(native-inputs
`(("python-pytest" ,python-pytest)
- ("python-pytest-cov" ,python-pytest-cov)
- ("python-pytest-runner" ,python-pytest-runner)))
+ ("python-pytest-cov" ,python-pytest-cov)))
(home-page "https://github.com/progrium/pyjwt")
(synopsis "JSON Web Token implementation in Python")
(description