summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2015-07-04 17:53:36 +0200
committerRicardo Wurmus <rekado@elephly.net>2015-07-04 17:55:30 +0200
commit151714ca8c39e5de10dd212f5e360cea06c51604 (patch)
treea46ec62cd685d477c85ed10265dc7e3a80293a8c /gnu
parente4fef9df271edaf1ce54c23da9e592efdc4f357d (diff)
downloadpatches-151714ca8c39e5de10dd212f5e360cea06c51604.tar
patches-151714ca8c39e5de10dd212f5e360cea06c51604.tar.gz
gnu: shogun: Build with install RPATH.
* gnu/packages/bioinformatics.scm (shogun)[arguments]: Add configure flag to build with install RPATH.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/bioinformatics.scm3
1 files changed, 2 insertions, 1 deletions
diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index 049e1c3308..6a3376d395 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -2346,7 +2346,8 @@ against local background noises.")
(lambda _ (setenv "HOME" "/tmp") #t)
%standard-phases))))
#:configure-flags
- (list "-DUSE_SVMLIGHT=OFF" ;disable proprietary SVMLIGHT
+ (list "-DCMAKE_BUILD_WITH_INSTALL_RPATH=TRUE"
+ "-DUSE_SVMLIGHT=OFF" ;disable proprietary SVMLIGHT
;;"-DJavaModular=ON" ;requires unpackaged jblas
;;"-DRubyModular=ON" ;requires unpackaged ruby-narray
;;"-DPerlModular=ON" ;"FindPerlLibs" does not exist