summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2013-09-16 19:00:47 +0200
committerLudovic Courtès <ludo@gnu.org>2013-09-16 21:39:07 +0200
commit803704418c4738ed63b3dd6aa893e3dc6da7d4db (patch)
treee3ff3b103e865bc554c63f84f3e2eb25623c2a27 /gnu
parentaae4ead8142d4fd7c674a1e6e302f40469f878c6 (diff)
downloadpatches-803704418c4738ed63b3dd6aa893e3dc6da7d4db.tar
patches-803704418c4738ed63b3dd6aa893e3dc6da7d4db.tar.gz
gnu: dbus: Add dependency on libX11.
* gnu/packages/glib.scm: Use #:export instead of 'define-public'. (dbus): Add LIBX11 as an input.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/glib.scm28
1 files changed, 21 insertions, 7 deletions
diff --git a/gnu/packages/glib.scm b/gnu/packages/glib.scm
index da15d404dd..815fafcbfb 100644
--- a/gnu/packages/glib.scm
+++ b/gnu/packages/glib.scm
@@ -35,9 +35,18 @@
#:use-module (gnu packages python)
#:use-module (gnu packages xml)
#:use-module (gnu packages bash)
- #:use-module (gnu packages file))
+ #:use-module (gnu packages file)
+ #:use-module (gnu packages xorg)
-(define-public dbus
+ ;; Export variables up-front to allow circular dependency with the 'xorg'
+ ;; module.
+ #:export (dbus
+ glib
+ dbus-glib
+ intltool
+ itstool))
+
+(define dbus
(package
(name "dbus")
(version "1.6.4")
@@ -64,7 +73,12 @@
`(("expat" ,expat)
("pkg-config" ,pkg-config)
("patch/localstatedir"
- ,(search-patch "dbus-localstatedir.patch"))))
+ ,(search-patch "dbus-localstatedir.patch"))
+
+ ;; Add a dependency on libx11 so that 'dbus-launch' has support for
+ ;; '--autolaunch'.
+ ("libx11" ,libx11)))
+
(home-page "http://dbus.freedesktop.org/")
(synopsis "Message bus for inter-process communication (IPC)")
(description
@@ -85,7 +99,7 @@ or through unencrypted TCP/IP suitable for use behind a firewall with
shared NFS home directories.")
(license license:gpl2+))) ; or Academic Free License 2.1
-(define-public glib
+(define glib
(package
(name "glib")
(version "2.37.1")
@@ -157,7 +171,7 @@ dynamic loading, and an object system.")
(home-page "http://developer.gnome.org/glib/")
(license license:lgpl2.0+))) ; some files are under lgpl2.1+
-(define-public intltool
+(define intltool
(package
(name "intltool")
(version "0.50.2")
@@ -198,7 +212,7 @@ The intltool collection can be used to do these things:
oaf files. This merge step will happen at build resp. installation time.")
(license license:gpl2+)))
-(define-public itstool
+(define itstool
(package
(name "itstool")
(version "1.2.0")
@@ -232,7 +246,7 @@ information in their documents, such as whether a particular element should be
translated.")
(license license:gpl3+)))
-(define-public dbus-glib
+(define dbus-glib
(package
(name "dbus-glib")
(version "0.100.2")