summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorLeo Famulari <leo@famulari.name>2019-02-01 12:21:38 +0100
committerLeo Famulari <leo@famulari.name>2019-02-01 17:21:10 +0100
commitbc58bb9bdfbe5b2128d96416611994f14b5b1757 (patch)
treee9bb36c84c1d6bdd45e46db83b641d19ac4da8ac /gnu
parentc4e4b85397a6fa48536a424dfd54b963459fe525 (diff)
downloadpatches-bc58bb9bdfbe5b2128d96416611994f14b5b1757.tar
patches-bc58bb9bdfbe5b2128d96416611994f14b5b1757.tar.gz
gnu: Add go-github-com-direnv-go-dotenv.
* gnu/packages/golang.scm (go-github-com-direnv-go-dotenv): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/golang.scm25
1 files changed, 25 insertions, 0 deletions
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index e6269f526f..cedfabe5bf 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -3365,3 +3365,28 @@ have super fancy logs.")
(synopsis "Filesystem-related functions for Go")
(description "Package fs provides filesystem-related functions.")
(license license:bsd-3))))
+
+(define-public go-github-com-direnv-go-dotenv
+ (let ((commit "4cce6d1a66f7bc8dc730eab85cab6af1b801abed")
+ (revision "0"))
+ (package
+ (name "go-github-com-direnv-go-dotenv")
+ (version (git-version "0.0.0" revision commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/direnv/go-dotenv")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "00wn4fc2lma0csf6ryvlc6k9jbpbifm4n7i3kkd2xrfw5qlm29b6"))))
+ (build-system go-build-system)
+ (arguments
+ '(#:import-path "github.com/direnv/go-dotenv"))
+ (home-page "https://github.com/direnv/go-dotenv")
+ (synopsis "Go dotenv parsing library")
+ (description "This package provides a library for parsing the dotenv
+format in Go.")
+ (license license:expat))))