summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2017-03-17 02:05:00 +0100
committerTobias Geerinckx-Rice <me@tobias.gr>2017-03-20 22:44:05 +0100
commit500fc65b5bd28a8f222d2dbff7676ba3ee622f12 (patch)
treee7794b93bb93758b28c84f9f8f25b2f355661fb8 /gnu
parentf0bce02664e5b5d56ccf0b2a6823599b0446f02f (diff)
downloadpatches-500fc65b5bd28a8f222d2dbff7676ba3ee622f12.tar
patches-500fc65b5bd28a8f222d2dbff7676ba3ee622f12.tar.gz
gnu: znc: Run test suite.
* gnu/packages/messaging.scm (znc)[arguments]: Enable tests. Add an ‘unpack-googletest’ phase and add ‘--with-gtest=’ to #:configure-flags. [native-inputs]: Add googletest source.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/messaging.scm18
1 files changed, 15 insertions, 3 deletions
diff --git a/gnu/packages/messaging.scm b/gnu/packages/messaging.scm
index 85c023514e..df56ac0793 100644
--- a/gnu/packages/messaging.scm
+++ b/gnu/packages/messaging.scm
@@ -10,6 +10,7 @@
;;; Copyright © 2016, 2017 Clément Lassieur <clement@lassieur.org>
;;; Copyright © 2017 Mekeor Melire <mekeor.melire@gmail.com>
;;; Copyright © 2017 Arun Isaac <arunisaac@systemreboot.net>
+;;; Copyright © 2017 Tobias Geerinckx-Rice <me@tobias.gr>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -399,12 +400,23 @@ compromised.")
"1jia6kq6bp8yxfj02d5vj9vqb4pylqcldspyjj6iz82kkka2a0ig"))))
(build-system gnu-build-system)
(arguments
- '(#:tests? #f ; tries to download GoogleTest with wget
+ `(#:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'unpack-googletest
+ (lambda* (#:key inputs #:allow-other-keys)
+ (zero? (system* "tar" "xf"
+ (assoc-ref inputs "googletest-source"))))))
#:configure-flags '("--enable-python"
"--enable-perl"
- "--enable-cyrus")))
+ "--enable-cyrus"
+ ,(string-append "--with-gtest="
+ "googletest-release-"
+ (package-version googletest)
+ "/googletest"))
+ #:test-target "test"))
(native-inputs
- `(("pkg-config" ,pkg-config)
+ `(("googletest-source" ,(package-source googletest))
+ ("pkg-config" ,pkg-config)
("perl" ,perl)
("python" ,python)))
(inputs