summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorPaul van der Walt <paul@denknerd.org>2015-10-15 15:18:31 +0200
committerPaul van der Walt <paul@denknerd.org>2015-10-23 09:10:52 +0200
commitfa67563caf1661f20c310b58e04b5871b6eac18b (patch)
treef6c39df8664b2fdad9708f42834bf74cc3503624 /gnu
parentf4e5c04ed15456a47c0e79fc80a6e5044de8a662 (diff)
downloadpatches-fa67563caf1661f20c310b58e04b5871b6eac18b.tar
patches-fa67563caf1661f20c310b58e04b5871b6eac18b.tar.gz
gnu: Add ghc-temporary-rc.
* gnu/packages/haskell.scm (ghc-temporary-rc): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/haskell.scm29
1 files changed, 29 insertions, 0 deletions
diff --git a/gnu/packages/haskell.scm b/gnu/packages/haskell.scm
index 825cda1b6a..edc0acd882 100644
--- a/gnu/packages/haskell.scm
+++ b/gnu/packages/haskell.scm
@@ -1322,6 +1322,35 @@ that you can use them without linking against Cabal or depending on it being
installed.")
(license bsd-3)))
+(define-public ghc-temporary-rc
+ (package
+ (name "ghc-temporary-rc")
+ (version "1.2.0.3")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append
+ "http://hackage.haskell.org/package/temporary-rc/temporary-rc-"
+ version
+ ".tar.gz"))
+ (sha256
+ (base32
+ "1nqih0qks439k3pr5kmbbc8rjdw730slrxlflqb27fbxbzb8skqs"))))
+ (build-system haskell-build-system)
+ (propagated-inputs `(("ghc-exceptions" ,ghc-exceptions)))
+ (home-page
+ "http://www.github.com/feuerbach/temporary")
+ (synopsis
+ "Portable temporary file and directory support")
+ (description
+ "The functions for creating temporary files and directories in the base
+library are quite limited. The unixutils package contains some good ones, but
+they aren't portable to Windows. This library just repackages the Cabal
+implementations of its own temporary file and folder functions so that you can
+use them without linking against Cabal or depending on it being installed.
+This is a better maintained fork of the \"temporary\" package.")
+ (license bsd-3)))
+
(define-public ghc-silently
(package
(name "ghc-silently")