summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorPaul van der Walt <paul@denknerd.org>2015-10-15 14:48:43 +0200
committerPaul van der Walt <paul@denknerd.org>2015-10-23 09:10:52 +0200
commitd76bf6181b083d85e6897ff8a27d72a4c457fbb4 (patch)
tree8ad491974410f6407e5d1f3b1fc34cfe00ba2e6f /gnu
parent6c1a7751a55617f43743529042e12e30bd1b4cd5 (diff)
downloadpatches-d76bf6181b083d85e6897ff8a27d72a4c457fbb4.tar
patches-d76bf6181b083d85e6897ff8a27d72a4c457fbb4.tar.gz
gnu: Add ghc-bytestring-builder.
* gnu/packages/haskell.scm (ghc-bytestring-builder): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/haskell.scm22
1 files changed, 22 insertions, 0 deletions
diff --git a/gnu/packages/haskell.scm b/gnu/packages/haskell.scm
index 2611727f37..3060d3bc70 100644
--- a/gnu/packages/haskell.scm
+++ b/gnu/packages/haskell.scm
@@ -2383,6 +2383,28 @@ or timeout period. This package provides alternative functions which use the
unbounded @code{Integer} type.")
(license bsd-3)))
+(define-public ghc-bytestring-builder
+ (package
+ (name "ghc-bytestring-builder")
+ (version "0.10.6.0.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append
+ "http://hackage.haskell.org/package/bytestring-builder"
+ "/bytestring-builder-" version ".tar.gz"))
+ (sha256
+ (base32
+ "1mkg24zl0rapb3gqzkyj5ibp07wx3yzd72hmfczssl0is63rjhww"))))
+ (build-system haskell-build-system)
+ (arguments `(#:haddock? #f)) ; Package contains no documentation.
+ (home-page "http://hackage.haskell.org/package/bytestring-builder")
+ (synopsis "The new bytestring builder, packaged outside of GHC")
+ (description "This package provides the bytestring builder that is
+debuting in bytestring-0.10.4.0, which should be shipping with GHC 7.8.
+Compatibility package for older packages.")
+ (license bsd-3)))
+
(define-public ghc-nats
(package
(name "ghc-nats")