summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2019-09-07 23:50:15 +0200
committerRicardo Wurmus <rekado@elephly.net>2019-09-08 00:30:32 +0200
commit7a5ed348c0073cb28dae01c10b25155e29188fdb (patch)
treea21adbbb00a8a77d242dcb60299cbaaa15673616 /gnu
parent1d03a9198db6f3656a34d62eb89e5f7d5a99e76a (diff)
downloadpatches-7a5ed348c0073cb28dae01c10b25155e29188fdb.tar
patches-7a5ed348c0073cb28dae01c10b25155e29188fdb.tar.gz
gnu: Add r-covr.
* gnu/packages/cran.scm (r-covr): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/cran.scm32
1 files changed, 32 insertions, 0 deletions
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index 5bf37e3900..44913e53f7 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -15212,3 +15212,35 @@ single cell integration, described in Korsunsky et al
@url{doi.org/10.1101/461954}. The package includes a standalone Harmony
function and interfaces to external frameworks.")
(license license:gpl3))))
+
+(define-public r-covr
+ (package
+ (name "r-covr")
+ (version "3.3.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "covr" version))
+ (sha256
+ (base32
+ "0fvd7v53w11x6kaw61hbml8n1j2ck9l2fv2wvqdsg689xic9rqcs"))))
+ (properties `((upstream-name . "covr")))
+ (build-system r-build-system)
+ (propagated-inputs
+ `(("r-crayon" ,r-crayon)
+ ("r-digest" ,r-digest)
+ ("r-httr" ,r-httr)
+ ("r-jsonlite" ,r-jsonlite)
+ ("r-rex" ,r-rex)
+ ("r-withr" ,r-withr)
+ ("r-yaml" ,r-yaml)))
+ (home-page "https://github.com/r-lib/covr")
+ (synopsis "Test coverage for R packages")
+ (description
+ "Thisp package enables you to track and report code coverage for your
+package and (optionally) upload the results to a coverage service. Code
+coverage is a measure of the amount of code being exercised by a set of tests.
+It is an indirect measure of test quality and completeness. This package is
+compatible with any testing methodology or framework and tracks coverage of
+both R code and compiled C/C++/FORTRAN code.")
+ (license license:gpl3)))