summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2018-12-25 10:29:41 +0200
committerEfraim Flashner <efraim@flashner.co.il>2018-12-25 11:11:36 +0200
commit215a51e4412f6e0051ce2f3abced8d26125d99ca (patch)
tree51aa131ad31c6778d1415e17a85e747a79fafc59 /gnu
parentbbc94a08f3d752b1d6221f610260912760264efb (diff)
downloadpatches-215a51e4412f6e0051ce2f3abced8d26125d99ca.tar
patches-215a51e4412f6e0051ce2f3abced8d26125d99ca.tar.gz
gnu: supertuxkart: Fix building with mesa@18.3.
* gnu/packages/games.scm (supertuxkart)[arguments]: Add custom phase to add newer '#define' to source.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/games.scm7
1 files changed, 7 insertions, 0 deletions
diff --git a/gnu/packages/games.scm b/gnu/packages/games.scm
index 4ab0af2e77..7896c9c3f4 100644
--- a/gnu/packages/games.scm
+++ b/gnu/packages/games.scm
@@ -2053,6 +2053,13 @@ This game is based on the GPL version of the famous game TuxRacer.")
"-DCMAKE_C_FLAGS=-fpermissive")
#:phases
(modify-phases %standard-phases
+ ;; see https://github.com/supertuxkart/stk-code/issues/3557
+ (add-after 'unpack 'patch-for-mesa-18.3
+ (lambda _
+ (substitute* "src/graphics/gl_headers.hpp"
+ (("#if !defined\\(USE_GLES2\\)")
+ "#if !defined(USE_GLES2)\n# define __gl_glext_h_"))
+ #t))
(add-after 'unpack 'unbundle
(lambda* (#:key inputs #:allow-other-keys)
(substitute* "CMakeLists.txt"