summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorOleg Pykhalov <go.wigust@gmail.com>2019-06-06 01:01:46 +0300
committerOleg Pykhalov <go.wigust@gmail.com>2019-06-06 09:53:29 +0300
commit8758086d2d25f2e58354febc3f01af586d0ee416 (patch)
tree0d9a3154c3f70cce37870ee76ffb97178e9fd0ae /gnu
parent2d906800fad33b53c17e041a0b5b9b4b8db81b1f (diff)
downloadpatches-8758086d2d25f2e58354febc3f01af586d0ee416.tar
patches-8758086d2d25f2e58354febc3f01af586d0ee416.tar.gz
gnu: emacs-dashboard: Update to 1.5.0.
* gnu/packages/emacs-xyz.scm (emacs-dashboard): Update to 1.5.0.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/emacs-xyz.scm17
1 files changed, 14 insertions, 3 deletions
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index e5b11e5422..543ac5b2c6 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -11931,7 +11931,7 @@ Emacs minor mode to escape sequences in code.")
(define-public emacs-dashboard
(package
(name "emacs-dashboard")
- (version "1.2.4")
+ (version "1.5.0")
(source
(origin
(method git-fetch)
@@ -11940,11 +11940,22 @@ Emacs minor mode to escape sequences in code.")
(commit version)))
(file-name (git-file-name name version))
(sha256
- (base32 "1hhh1kfsz87qfmh45wjf2r93rz79rq0vbyxlfrsl02092zjbl1zr"))))
+ (base32 "0ihpcagwgc9qy70lf2y3dvx2bm5h9lnqh4sx6643cr8pp06ysbvq"))))
(build-system emacs-build-system)
(propagated-inputs
`(("emacs-page-break-lines" ,emacs-page-break-lines)))
- (arguments '(#:include '("\\.el$" "\\.txt$" "\\.png$")))
+ (arguments
+ '(#:include '("\\.el$" "\\.txt$" "\\.png$")
+ #:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'patch-dashboard-widgets
+ ;; This phase fixes compilation error.
+ (lambda _
+ (chmod "dashboard-widgets.el" #o666)
+ (emacs-substitute-variables "dashboard-widgets.el"
+ ("dashboard-init-info"
+ '(format "Loaded in %s" (emacs-init-time))))
+ #t)))))
(home-page "https://github.com/rakanalh/emacs-dashboard")
(synopsis "Startup screen extracted from Spacemacs")
(description "This package provides an extensible Emacs dashboard, with