summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2019-02-02 11:29:50 +0100
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2019-02-02 11:29:50 +0100
commit352033f31b09fb0632423c0926180d9b366b0624 (patch)
tree558b4f295ef8e04afee1cfe17a9028a1654f53b8 /gnu
parent57b663fa8fcc22d9c89fd919aca4c3c13465c819 (diff)
downloadpatches-352033f31b09fb0632423c0926180d9b366b0624.tar
patches-352033f31b09fb0632423c0926180d9b366b0624.tar.gz
gnu: python-duniterpy: Update to 0.52.0.
* gnu/packages/finance.scm (python-duniterpy): Update to 0.52.0. [propagated-inputs]: Add python-pyaes.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/finance.scm23
1 files changed, 12 insertions, 11 deletions
diff --git a/gnu/packages/finance.scm b/gnu/packages/finance.scm
index 250b1db144..45aa89ea82 100644
--- a/gnu/packages/finance.scm
+++ b/gnu/packages/finance.scm
@@ -855,7 +855,7 @@ Luhn and family of ISO/IEC 7064 check digit algorithms. ")
(define-public python-duniterpy
(package
(name "python-duniterpy")
- (version "0.51.0")
+ (version "0.52.0")
(source
(origin
(method git-fetch)
@@ -866,7 +866,7 @@ Luhn and family of ISO/IEC 7064 check digit algorithms. ")
(file-name (git-file-name name version))
(sha256
(base32
- "074mh2kh3s00ib0h99050ss3j4c51v57py6dzm7crida6l0iydbv"))))
+ "07liba2d21hb8m3n6yccfamq9yq0ryywh18vs9g2sgywfsnv82lh"))))
(build-system python-build-system)
(arguments
;; Tests fail with "AttributeError: module 'attr' has no attribute 's'".
@@ -884,16 +884,17 @@ Luhn and family of ISO/IEC 7064 check digit algorithms. ")
(copy-recursively "docs/_build/html" doc))
#t)))))
(native-inputs
- `(("python-sphinx" ,python-sphinx)
- ("python-sphinx-rtd-theme" ,python-sphinx-rtd-theme)))
+ `(("sphinx" ,python-sphinx)
+ ("sphinx-rtd-theme" ,python-sphinx-rtd-theme)))
(propagated-inputs
- `(("python-aiohttp" ,python-aiohttp)
- ("python-attr" ,python-attr)
- ("python-base58" ,python-base58)
- ("python-jsonschema" ,python-jsonschema)
- ("python-libnacl" ,python-libnacl)
- ("python-pylibscrypt" ,python-pylibscrypt)
- ("python-pypeg2" ,python-pypeg2)))
+ `(("aiohttp" ,python-aiohttp)
+ ("attr" ,python-attr)
+ ("base58" ,python-base58)
+ ("jsonschema" ,python-jsonschema)
+ ("libnacl" ,python-libnacl)
+ ("pyaes" ,python-pyaes)
+ ("pylibscrypt" ,python-pylibscrypt)
+ ("pypeg2" ,python-pypeg2)))
(home-page "https://git.duniter.org/clients/python/duniterpy")
(synopsis "Python implementation of Duniter API")
(description "@code{duniterpy} is an implementation of