summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2018-02-12 22:07:50 +0100
committerRicardo Wurmus <rekado@elephly.net>2018-02-13 13:37:35 +0100
commit05c08ec9f60851aa72b5eaf67ab7d2da2ffde872 (patch)
treeb181f97127335c6bbd7335a4f30cd6a87efb5f28 /gnu
parent9656e6e8628989c865c9f17befc4c5af40d83a60 (diff)
downloadpatches-05c08ec9f60851aa72b5eaf67ab7d2da2ffde872.tar
patches-05c08ec9f60851aa72b5eaf67ab7d2da2ffde872.tar.gz
gnu: ghc-fast-logger: Update to 2.4.11.
* gnu/packages/haskell.scm (ghc-fast-logger): Update to 2.4.11. [inputs]: Add ghc-easy-file and ghc-unix-time; remove ghc-bytestring-builder.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/haskell.scm11
1 files changed, 6 insertions, 5 deletions
diff --git a/gnu/packages/haskell.scm b/gnu/packages/haskell.scm
index dbfada701c..90388d17bf 100644
--- a/gnu/packages/haskell.scm
+++ b/gnu/packages/haskell.scm
@@ -4427,7 +4427,7 @@ monad transformer (instead of the IO monad).")
(define-public ghc-fast-logger
(package
(name "ghc-fast-logger")
- (version "2.4.1")
+ (version "2.4.11")
(source
(origin
(method url-fetch)
@@ -4437,12 +4437,13 @@ monad transformer (instead of the IO monad).")
".tar.gz"))
(sha256
(base32
- "0kjk1861qcls8m8y7i55msfpprws5wk6c5mxzi35g2qbl2sih4p5"))))
+ "1ad2vq4nifdxshqk9yrmghqizhkgybfz134kpr6padglb2mxxrdv"))))
(build-system haskell-build-system)
(inputs
- `(("ghc-bytestring-builder" ,ghc-bytestring-builder)
- ("ghc-auto-update" ,ghc-auto-update)
- ("ghc-text" ,ghc-text)))
+ `(("ghc-auto-update" ,ghc-auto-update)
+ ("ghc-easy-file" ,ghc-easy-file)
+ ("ghc-text" ,ghc-text)
+ ("ghc-unix-time" ,ghc-unix-time)))
(native-inputs
`(("hspec-discover" ,hspec-discover)
("ghc-hspec" ,ghc-hspec)))