summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorAndreas Enge <andreas@enge.fr>2013-12-18 14:24:34 +0100
committerAndreas Enge <andreas@enge.fr>2013-12-18 14:24:34 +0100
commite148203588ced50887e4e1d0ba29730acc8bf4b9 (patch)
treedf153a275302068684d9922a7585d409896216be /gnu
parenta53421fddab7c15f851e6a9cf0d14bb87cbbea28 (diff)
downloadpatches-e148203588ced50887e4e1d0ba29730acc8bf4b9.tar
patches-e148203588ced50887e4e1d0ba29730acc8bf4b9.tar.gz
gnu: shishi: Use libgcrypt-1.5.
* gnu/packages/shishi.scm (shishi): Use input libgcrypt-1.5 instead of 1.6.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/shishi.scm10
1 files changed, 9 insertions, 1 deletions
diff --git a/gnu/packages/shishi.scm b/gnu/packages/shishi.scm
index 2f5fa8a37c..0523a4eef5 100644
--- a/gnu/packages/shishi.scm
+++ b/gnu/packages/shishi.scm
@@ -43,7 +43,15 @@
(inputs
`(("gnutls" ,gnutls)
("zlib" ,zlib)
- ("libgcrypt" ,libgcrypt)
+ ;; libgcrypt 1.6 fails because of the following test:
+ ;; #include <gcrypt.h>
+ ;; /* GCRY_MODULE_ID_USER was added in 1.4.4 and gc-libgcrypt.c
+ ;; will fail on startup if we don't have 1.4.4 or later, so
+ ;; test for it early. */
+ ;; #if !defined GCRY_MODULE_ID_USER
+ ;; error too old libgcrypt
+ ;; #endif
+ ("libgcrypt" ,libgcrypt-1.5)
("libtasn1" ,libtasn1)))
(home-page "http://www.gnu.org/software/shishi/")
(synopsis "Implementation of the Kerberos 5 network security system")