summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorBen Woodcroft <donttrustben@gmail.com>2016-12-30 17:21:37 +1000
committerBen Woodcroft <donttrustben@gmail.com>2016-12-30 17:22:43 +1000
commita29929b32caf9e437d18bdb0cd4d1b22bc096fed (patch)
tree734a3f6f9a2e56a86f0c50d4285113c8afb5938d /gnu
parent95d7d0c57f2f79419b8ca396c2ff1d1cd651dff7 (diff)
downloadpatches-a29929b32caf9e437d18bdb0cd4d1b22bc096fed.tar
patches-a29929b32caf9e437d18bdb0cd4d1b22bc096fed.tar.gz
gnu: multiqc: Update to 0.9.
Suggested by Raoul Bonnal <ilpuccio.febo@gmail.com>. * gnu/packages/bioinformatics.scm (multiqc): Update to 0.9. [origin]: Add patch. * gnu/packages/patches/multiqc-fix-git-subprocess-error.patch: New file. * gnu/local.mk (dist_patch_DATA): Add it.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/local.mk1
-rw-r--r--gnu/packages/bioinformatics.scm9
-rw-r--r--gnu/packages/patches/multiqc-fix-git-subprocess-error.patch16
3 files changed, 24 insertions, 2 deletions
diff --git a/gnu/local.mk b/gnu/local.mk
index 38c1b0b94e..b7c182fbf6 100644
--- a/gnu/local.mk
+++ b/gnu/local.mk
@@ -730,6 +730,7 @@ dist_patch_DATA = \
%D%/packages/patches/mpc123-initialize-ao.patch \
%D%/packages/patches/mplayer2-theora-fix.patch \
%D%/packages/patches/module-init-tools-moduledir.patch \
+ %D%/packages/patches/multiqc-fix-git-subprocess-error.patch \
%D%/packages/patches/mumps-build-parallelism.patch \
%D%/packages/patches/mupdf-build-with-openjpeg-2.1.patch \
%D%/packages/patches/mupen64plus-ui-console-notice.patch \
diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index 07c4a0a1b7..54c8ce0f63 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -7855,15 +7855,20 @@ replacement for strverscmp.")
(define-public multiqc
(package
(name "multiqc")
- (version "0.6")
+ (version "0.9")
(source
(origin
(method url-fetch)
(uri (pypi-uri "multiqc" version))
(sha256
(base32
- "0avw11h63ldpxy5pizc3wl1wa01ha7q10wb240nggsjz3jaqvyiy"))))
+ "12gs1jw2jrxrij529rnl5kaqxfcqn15yzcsggxkfhdx634ml0cny"))
+ (patches (search-patches "multiqc-fix-git-subprocess-error.patch"))))
(build-system python-build-system)
+ (arguments
+ ;; Tests are to be introduced in the next version, see
+ ;; https://github.com/ewels/MultiQC/issues/376
+ `(#:tests? #f))
(propagated-inputs
`(("python-jinja2" ,python-jinja2)
("python-simplejson" ,python-simplejson)
diff --git a/gnu/packages/patches/multiqc-fix-git-subprocess-error.patch b/gnu/packages/patches/multiqc-fix-git-subprocess-error.patch
new file mode 100644
index 0000000000..87be6142f4
--- /dev/null
+++ b/gnu/packages/patches/multiqc-fix-git-subprocess-error.patch
@@ -0,0 +1,16 @@
+Without this patch, the incorrect exception is caught when 'git' is not in
+PATH. See https://github.com/ewels/MultiQC/pull/377.
+
+diff --git a/multiqc/utils/config.py b/multiqc/utils/config.py
+index 01fa554..4a11793 100755
+--- a/multiqc/utils/config.py
++++ b/multiqc/utils/config.py
+@@ -28,7 +28,7 @@ try:
+ git_hash = subprocess.check_output(['git', 'rev-parse', 'HEAD'], stderr=subprocess.STDOUT)
+ git_hash_short = git_hash[:7]
+ version = '{} ({})'.format(version, git_hash_short)
+-except subprocess.CalledProcessError:
++except (subprocess.CalledProcessError, FileNotFoundError):
+ pass
+ os.chdir(cwd)
+