summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2015-10-08 17:58:06 +0200
committerLudovic Courtès <ludo@gnu.org>2015-10-08 18:08:16 +0200
commit9765b3aeac88ae9c9ffc38ed6d1f8dcbd9abca7b (patch)
treeeea31012bce0355a8803953c7b12f8844adcd3d1 /gnu
parentb81378251c629615aff0d62ca686bb53a10367de (diff)
downloadpatches-9765b3aeac88ae9c9ffc38ed6d1f8dcbd9abca7b.tar
patches-9765b3aeac88ae9c9ffc38ed6d1f8dcbd9abca7b.tar.gz
Revert "gnu: python: Do not retain references to build tools."
This reverts commit 14f8dae6b1e42cfd37678d64c137932b91656a41, which was unintentionally pushed (it does not work with Python 3.)
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/python.scm18
1 files changed, 0 insertions, 18 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index 166e8d4944..ee9173b570 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -156,24 +156,6 @@
(("/bin/sh") (which "sh")))
#t))
(add-before
- 'install 'do-not-record-configure-flags
- (lambda _
- ;; Remove configure flags from '_sysconfigdata.py' so we don't
- ;; end up keeping references to the build tools.
- (substitute* (find-files "." "sysconfigdata\\.py$")
- (("'CONFIG_ARGS':.*")
- "'CONFIG_ARGS': \"\",\n"))
- #t))
- (add-after
- 'install 'do-not-record-configure-flags-in-makefile
- (lambda* (#:key outputs #:allow-other-keys)
- ;; Likewise.
- (let ((out (assoc-ref outputs "out")))
- (substitute* (find-files out "^Makefile$")
- (("^CONFIG_ARGS[[:blank:]]*=.*$")
- "CONFIG_ARGS =\n"))
- #t)))
- (add-before
'check 'pre-check
(lambda _
;; 'Lib/test/test_site.py' needs a valid $HOME