summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorEric Bavier <bavier@member.fsf.org>2015-11-23 14:58:00 -0600
committerEric Bavier <bavier@member.fsf.org>2015-11-24 11:41:46 -0600
commit97003b5ccc765d481287bdb0d2a02a5db3efcb15 (patch)
tree9765a94379e9e35b33dce22075eb6a3af0016464 /gnu
parentcc3de1da418e1718ab4ff85144a56f573460fbd6 (diff)
downloadpatches-97003b5ccc765d481287bdb0d2a02a5db3efcb15.tar
patches-97003b5ccc765d481287bdb0d2a02a5db3efcb15.tar.gz
gnu: gnuplot: Update to 5.0.1.
* gnu/packages/maths.scm (gnuplot): Update to 5.0.1. (native-inputs): 'texlive' -> 'texlive-bin'.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/maths.scm12
1 files changed, 7 insertions, 5 deletions
diff --git a/gnu/packages/maths.scm b/gnu/packages/maths.scm
index 5af784c47f..0c0f013ca4 100644
--- a/gnu/packages/maths.scm
+++ b/gnu/packages/maths.scm
@@ -337,22 +337,24 @@ singular value problems.")
(define-public gnuplot
(package
(name "gnuplot")
- (version "4.6.3")
+ (version "5.0.1")
(source
(origin
(method url-fetch)
(uri (string-append "mirror://sourceforge/gnuplot/gnuplot/"
- version "/gnuplot-" version ".tar.gz"))
+ version "/gnuplot-" version ".tar.gz"))
(sha256
(base32
- "1xd7gqdhlk7k1p9yyqf9vkk811nadc7m4si0q3nb6cpv4pxglpyz"))))
+ "0irwig94w3f8bn4a444hrjnp7w55vqwv8gqj42jiwn6zf5z5bg3w"))))
(build-system gnu-build-system)
(inputs `(("readline" ,readline)
("cairo" ,cairo)
("pango" ,pango)
("gd" ,gd)))
- (native-inputs `(("texlive" ,texlive)
- ("pkg-config" ,pkg-config)))
+ (native-inputs `(("pkg-config" ,pkg-config)
+ ;; Need 'tex', 'latex', 'pdflatex', 'kpsexand', and
+ ;; 'texhash' binaries.
+ ("texlive" ,texlive-bin)))
(home-page "http://www.gnuplot.info")
(synopsis "Command-line driven graphing utility")
(description "Gnuplot is a portable command-line driven graphing