summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2014-03-10 23:51:31 +0100
committerLudovic Courtès <ludo@gnu.org>2014-03-10 23:54:27 +0100
commit8be3b8a39bae9ffaccf3c9a71104d67e73948b20 (patch)
treefd1deee8449274908f6c2147d5df00b975ee4b68 /gnu
parente06f7865e2630494a522ac32b9c0a0311be3e1e2 (diff)
downloadpatches-8be3b8a39bae9ffaccf3c9a71104d67e73948b20.tar
patches-8be3b8a39bae9ffaccf3c9a71104d67e73948b20.tar.gz
Change default store values from /nix/store to /gnu/store.
* gnu/packages/ld-wrapper.scm (%store-directory): Change the default to /gnu/store. * guix/build/utils.scm (%store-directory): New procedure. (remove-store-references): Use it for the default value of 'store'. * guix/packages.scm (patch-and-repack)[builder]: Change default store to /gnu/store.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/ld-wrapper.scm4
1 files changed, 2 insertions, 2 deletions
diff --git a/gnu/packages/ld-wrapper.scm b/gnu/packages/ld-wrapper.scm
index 41ff3df986..d3eb083f2f 100644
--- a/gnu/packages/ld-wrapper.scm
+++ b/gnu/packages/ld-wrapper.scm
@@ -11,7 +11,7 @@ main="(@ (gnu build-support ld-wrapper) ld-wrapper)"
exec @GUILE@ -c "(load-compiled \"$0.go\") (apply $main (cdr (command-line)))" "$@"
!#
;;; GNU Guix --- Functional package management for GNU
-;;; Copyright © 2012, 2013 Ludovic Courtès <ludo@gnu.org>
+;;; Copyright © 2012, 2013, 2014 Ludovic Courtès <ludo@gnu.org>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -63,7 +63,7 @@ exec @GUILE@ -c "(load-compiled \"$0.go\") (apply $main (cdr (command-line)))" "
(define %store-directory
;; File name of the store.
- (or (getenv "NIX_STORE") "/nix/store"))
+ (or (getenv "NIX_STORE") "/gnu/store"))
(define %temporary-directory
;; Temporary directory.