summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorCyril Roelandt <tipecaml@gmail.com>2013-10-15 00:34:35 +0200
committerCyril Roelandt <tipecaml@gmail.com>2013-12-15 23:39:43 +0100
commit7a8605ceb54f8c91d968ad6e6e4d247db776d03e (patch)
tree78069e15bf70c41a120f710650f504bd7e7d93d7 /gnu
parentaf949e8ee7e134e30e559dcfa9cf59a3d28ea350 (diff)
downloadpatches-7a8605ceb54f8c91d968ad6e6e4d247db776d03e.tar
patches-7a8605ceb54f8c91d968ad6e6e4d247db776d03e.tar.gz
gnu: Add libpeas.
* gnu/packages/gnome.scm (libpeas): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/gnome.scm64
1 files changed, 64 insertions, 0 deletions
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index 0c1b047290..9362283d5a 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -359,3 +359,67 @@ notification daemon, as defined in the Desktop Notifications spec. These
notifications can be used to inform the user about an event or display
some form of information without getting in the user's way.")
(license lgpl2.1+)))
+
+(define-public libpeas
+ (package
+ (name "libpeas")
+ (version "1.9.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "mirror://gnome/sources/" name "/"
+ (substring version 0 (string-rindex version #\.)) "/"
+ name "-" version ".tar.xz"))
+ (sha256
+ (base32
+ "13fzyzv6c0cfdj83z1s16lv8k997wpnzyzr0wfwcfkcmvz64g1q0"))))
+ (build-system gnu-build-system)
+ (arguments
+ `(#:modules ((guix build gnome)
+ (guix build gnu-build-system)
+ (guix build utils))
+ #:imported-modules ((guix build gnome)
+ (guix build gnu-build-system)
+ (guix build utils))
+ #:phases
+ (alist-replace
+ 'configure
+ (lambda* (#:key inputs #:allow-other-keys #:rest args)
+ (let ((configure (assoc-ref %standard-phases 'configure)))
+ (substitute* "libpeas-gtk/Makefile.in"
+ (("--add-include-path")
+ (string-append
+ " --add-include-path=" (gir-directory inputs "atk")
+ " --add-include-path=" (gir-directory inputs "gdk-pixbuf")
+ " --add-include-path=" (gir-directory inputs "gtk+")
+ " --add-include-path=" (gir-directory inputs "pango")
+ " --add-include-path")))
+ (substitute* "libpeas-gtk/Makefile.in"
+ (("--includedir=\\$\\(top_builddir")
+ (string-append
+ " --includedir=" (gir-directory inputs "atk")
+ " --includedir=" (gir-directory inputs "gdk-pixbuf")
+ " --includedir=" (gir-directory inputs "gtk+")
+ " --includedir=" (gir-directory inputs "pango")
+ " --includedir=$(top_builddir")))
+ (apply configure args)))
+ %standard-phases)))
+ (inputs
+ `(("atk" ,atk)
+ ("gdk-pixbuf" ,gdk-pixbuf)
+ ("glib" ,glib)
+ ("gobject-introspection" ,gobject-introspection)
+ ("gtk+" ,gtk+)
+ ("intltool" ,intltool)
+ ("pango" ,pango)
+ ("pkg-config" ,pkg-config)))
+ (home-page "https://wiki.gnome.org/Libpeas")
+ (synopsis "GObject plugin system")
+ (description
+ "libpeas is a gobject-based plugins engine, and is targetted at giving
+every application the chance to assume its own extensibility. It also has a
+set of features including, but not limited to: multiple extension points; on
+demand (lazy) programming language support for C, Python and JS; simplicity of
+the API")
+
+ (license lgpl2.0+)))