summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorJan Nieuwenhuizen <janneke@gnu.org>2018-11-16 21:30:28 +0100
committerJan Nieuwenhuizen <janneke@gnu.org>2018-11-18 16:45:03 +0100
commit4fd4efc812b18c11a2ed22a13befc630f5b95434 (patch)
tree2c794da622d11c27391cb7f906a324ee8d4ac799 /gnu
parent562c37c7beaea9e6912d5ae1c7f7dc8d2a2a3a64 (diff)
downloadpatches-4fd4efc812b18c11a2ed22a13befc630f5b95434.tar
patches-4fd4efc812b18c11a2ed22a13befc630f5b95434.tar.gz
bootstrap: Replace %mescc-tools-seed with %bootstrap-mescc-tools.
* gnu/packages/bootstrap.scm (%mescc-tools-seed): Remove. (%bootstrap-inputs): Replace %mescc-tools-seed with %bootstrap-mescc-tools. * gnu/packages/commencement.scm (mes-boot): Likewise. (tcc-boot0): Likewise. (mescc-tools-boot): Remove.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/bootstrap.scm14
-rw-r--r--gnu/packages/commencement.scm78
2 files changed, 3 insertions, 89 deletions
diff --git a/gnu/packages/bootstrap.scm b/gnu/packages/bootstrap.scm
index 620f888eb0..93e9d8ddbd 100644
--- a/gnu/packages/bootstrap.scm
+++ b/gnu/packages/bootstrap.scm
@@ -51,7 +51,6 @@
%bootstrap-inputs
%bootstrap-mescc-tools
%bootstrap-mes
- %mescc-tools-seed
%srfi-43))
;;; Commentary:
@@ -713,17 +712,6 @@ exec ~a/bin/.gcc-wrapped -B~a/lib \
(home-page #f)
(license gpl3+)))
-(define %mescc-tools-seed ; todo: add tarballs to alpha.gnu.org/pub/mes/bootstrap/
- (let ((commit "dc4e20e74924a5c80a2b7a77b4d7b927234fa71c"))
- (origin
- (method url-fetch)
- (uri (string-append "https://gitlab.com/janneke/mescc-tools-seed"
- "/-/archive/" commit
- "/mescc-tools-seed-" commit ".tar.gz"))
- (sha256
- (base32
- "1lj7df73vxanmffmiwkhcn83r7yd9n8568nkki06bqq5zg526nyz")))))
-
(define %srfi-43
(origin
(method url-fetch)
@@ -739,7 +727,7 @@ exec ~a/bin/.gcc-wrapped -B~a/lib \
`(,@(match (%current-system)
((or "i686-linux" "x86_64-linux")
`(("linux-libre-headers" ,%bootstrap-linux-libre-headers)
- ("mescc-tools-seed" ,%mescc-tools-seed)
+ ("bootstrap-mescc-tools" ,%bootstrap-mescc-tools)
("mes" ,%bootstrap-mes)
("srfi-43" ,%srfi-43 )))
(_
diff --git a/gnu/packages/commencement.scm b/gnu/packages/commencement.scm
index 4def178a83..ed8a429c23 100644
--- a/gnu/packages/commencement.scm
+++ b/gnu/packages/commencement.scm
@@ -106,79 +106,6 @@
(native-inputs '())
(propagated-inputs '()))))
-(define mescc-tools-boot
- (package-with-bootstrap-guile
- (package
- (inherit mescc-tools)
- (name "mescc-tools-boot")
- (version "0.5.2")
- (source (origin
- (method url-fetch)
- (uri (string-append
- "http://git.savannah.nongnu.org/cgit/mescc-tools.git/snapshot/"
- name "-Release_" version
- ".tar.gz"))
- (patches (search-patches "mescc-tools-boot.patch"))
- (file-name (string-append "mescc-tools" "-" version ".tar.gz"))
- (sha256
- (base32
- "01x7bhmgwyf6mc2g1hcvibhps98nllacqm4f0j5l51b1mbi18pc2"))))
- (inputs '())
- (propagated-inputs '())
- (native-inputs
- `(("mescc-tools-seed" ,%mescc-tools-seed)
- ("mes-source" ,(package-source mes-boot0))
-
- ("bootstrap-mes" ,%bootstrap-mes)
- ("coreutils" ,%bootstrap-coreutils&co)))
- (build-system gnu-build-system)
- (arguments
- `(#:implicit-inputs? #f
- #:guile ,%bootstrap-guile
- #:strip-binaries? #f ; binutil's strip b0rkes MesCC/M1/hex2 binaries
- #:phases
- (modify-phases %standard-phases
- (add-after 'unpack 'unpack-seeds
- (lambda* (#:key outputs #:allow-other-keys)
- (let* ((coreutils (assoc-ref %build-inputs "coreutils"))
- (mescc-tools-seed (assoc-ref %build-inputs "mescc-tools-seed"))
- (mes-source (assoc-ref %build-inputs "mes-source"))
- (out (assoc-ref %outputs "out")))
- (with-directory-excursion ".."
- (and
- (mkdir-p "mescc-tools-seed")
- (invoke "tar" "--strip=1" "-C" "mescc-tools-seed"
- "-xvf" mescc-tools-seed)
- (mkdir-p "mes-source")
- (invoke "tar" "--strip=1" "-C" "mes-source"
- "-xvf" mes-source)
- #t)))))
- (replace 'configure
- (lambda* (#:key outputs #:allow-other-keys)
- (let ((coreutils (assoc-ref %build-inputs "coreutils"))
- (bootstrap-mes (assoc-ref %build-inputs "bootstrap-mes"))
- (out (assoc-ref %outputs "out")))
- (setenv "PATH" (string-append coreutils "/bin"
- ":" "../mescc-tools-seed"))
- (format (current-error-port) "PATH=~s\n" (getenv "PATH"))
- (setenv "PREFIX" out)
- (setenv "MES_PREFIX" "../mes-source")
- (setenv "MESCC_TOOLS_SEED" "../mescc-tools-seed")
- (setenv "MES_SEED" (string-append bootstrap-mes "/lib"))
- #t)))
- (replace 'build
- (lambda _
- (invoke "sh" "build.sh")))
- (replace 'check
- (lambda _
- ;; bootstrap build.sh lacks exec_enable, get_machine, and
- ;; kaem_machine
- ;; (invoke "sh" "check.sh")
- #t))
- (replace 'install
- (lambda _
- (invoke "sh" "install.sh")))))))))
-
(define nyacc-boot
(let ((version "0.86.0")
(revision "0")
@@ -211,7 +138,7 @@
(inputs '())
(propagated-inputs '())
(native-inputs
- `(("mescc-tools" ,mescc-tools-boot)
+ `(("mescc-tools" ,%bootstrap-mescc-tools)
("nyacc-source" ,(package-source nyacc-boot))
("coreutils" , %bootstrap-coreutils&co)
@@ -332,7 +259,7 @@
(propagated-inputs '())
(native-inputs
`(("mes" ,mes-boot)
- ("mescc-tools" ,mescc-tools-boot)
+ ("mescc-tools" ,%bootstrap-mescc-tools)
("nyacc-source" ,(package-source nyacc-boot))
("coreutils" , %bootstrap-coreutils&co)
@@ -393,7 +320,6 @@
(setenv "OBJDUMP" "true")
(setenv "ONE_SOURCE" "1")
(setenv "PREPROCESS" "1")
- (setenv "MES_DEBUG" "1")
(setenv "MES_ARENA" "70000000")
(setenv "MES_MAX_ARENA" "70000000")