summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2014-03-23 21:49:20 +0100
committerLudovic Courtès <ludo@gnu.org>2014-03-24 01:10:17 +0100
commit2ed6aa9e398b99296144dca364012f41764a8e89 (patch)
tree5c4352cdc3ac69d31e155219a0b6d07763b32aaa /gnu
parent1eefbb2693f0f29f8f095af9f067240b85e735aa (diff)
downloadpatches-2ed6aa9e398b99296144dca364012f41764a8e89.tar
patches-2ed6aa9e398b99296144dca364012f41764a8e89.tar.gz
gnu: glibc: Patch mtrace.pl to avoid retaining a reference to Perl.
* gnu/packages/base.scm (glibc)[argument] <pre-configure phase>: Patch malloc/mtrace.pl.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/base.scm12
1 files changed, 11 insertions, 1 deletions
diff --git a/gnu/packages/base.scm b/gnu/packages/base.scm
index 1f6e86341f..bf1ebfa629 100644
--- a/gnu/packages/base.scm
+++ b/gnu/packages/base.scm
@@ -474,7 +474,17 @@ library for working with executable and object formats is also included.")
;; Same for `popen'.
(substitute* "libio/iopopen.c"
(("/bin/sh")
- (string-append out "/bin/bash")))))
+ (string-append out "/bin/bash")))
+
+ ;; Make sure we don't retain a reference to the
+ ;; bootstrap Perl.
+ (substitute* "malloc/mtrace.pl"
+ (("^#!.*")
+ ;; The shebang can be omitted, because there's the
+ ;; "bilingual" eval/exec magic at the top of the file.
+ "")
+ (("exec @PERL@")
+ "exec perl"))))
(alist-cons-after
'install 'install-locales
(lambda _