summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorAl McElrath <hello@yrns.org>2016-05-07 19:59:00 -0700
committer宋文武 <iyzsong@gmail.com>2016-05-09 18:11:56 +0800
commit4acbd2062198ff5eacaa6f0bbba9096b228badde (patch)
tree986fd20f2fb11fcc993bbb73dcddd9c084515664 /gnu
parent9c6b7ef54fa5e4dac0e21e16dee4dc54858250a2 (diff)
downloadpatches-4acbd2062198ff5eacaa6f0bbba9096b228badde.tar
patches-4acbd2062198ff5eacaa6f0bbba9096b228badde.tar.gz
gnu: Add surf.
* gnu/packages/suckless.scm (surf): New variable. Signed-off-by: 宋文武 <iyzsong@gmail.com>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/suckless.scm39
1 files changed, 39 insertions, 0 deletions
diff --git a/gnu/packages/suckless.scm b/gnu/packages/suckless.scm
index c921f8e767..f582aea42f 100644
--- a/gnu/packages/suckless.scm
+++ b/gnu/packages/suckless.scm
@@ -1,6 +1,7 @@
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2013 Cyril Roelandt <tipecaml@gmail.com>
;;; Copyright © 2015 Amirouche Boubekki <amirouche@hypermove.net>
+;;; Copyright © 2016 Al McElrath <hello@yrns.org>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -22,10 +23,13 @@
#:use-module (guix packages)
#:use-module (guix download)
#:use-module (guix build-system gnu)
+ #:use-module (guix build-system glib-or-gtk)
#:use-module (gnu packages)
+ #:use-module (gnu packages gnome)
#:use-module (gnu packages xorg)
#:use-module (gnu packages fonts)
#:use-module (gnu packages pkg-config)
+ #:use-module (gnu packages webkit)
#:use-module (gnu packages fontutils))
(define-public dwm
@@ -189,3 +193,38 @@ implements 256 colors, most VT10X escape sequences, utf8, X11 copy/paste,
antialiased fonts (using fontconfig), fallback fonts, resizing, and line
drawing.")
(license license:x11)))
+
+(define-public surf
+ (package
+ (name "surf")
+ (version "0.7")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "http://dl.suckless.org/surf/surf-"
+ version ".tar.gz"))
+ (sha256
+ (base32
+ "0jj93izd8fizxfa6ln9w1h9bwki81sz5dhskh5x1rl34zd38aq4m"))))
+ (build-system glib-or-gtk-build-system)
+ (arguments
+ '(#:tests? #f ; no tests
+ #:make-flags (list "CC=gcc"
+ (string-append "PREFIX=" %output))
+ #:phases
+ (modify-phases %standard-phases
+ (delete 'configure))))
+ (inputs
+ `(("glib-networking" ,glib-networking)
+ ("gsettings-desktop-schemas" ,gsettings-desktop-schemas)
+ ("webkitgtk" ,webkitgtk/gtk+-2)))
+ (native-inputs
+ `(("pkg-config" ,pkg-config)))
+ (home-page "http://surf.suckless.org/")
+ (synopsis "Simple web browser")
+ (description
+ "Surf is a simple web browser based on WebKit/GTK+. It is able to
+display websites and follow links. It supports the XEmbed protocol which
+makes it possible to embed it in another application. Furthermore, one can
+point surf to another URI by setting its XProperties.")
+ (license license:x11)))