summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2018-02-12 19:44:38 +0100
committerRicardo Wurmus <rekado@elephly.net>2018-02-13 13:37:32 +0100
commitd0f4853a9cfdb7c3b74c28954b8cccafd055ebfe (patch)
treefb8426b7026f4a26bb84810cb483f53d1f7f9c98 /gnu
parent0f55dff335981c20ca9d5d65bcb7136efd40ea74 (diff)
downloadpatches-d0f4853a9cfdb7c3b74c28954b8cccafd055ebfe.tar
patches-d0f4853a9cfdb7c3b74c28954b8cccafd055ebfe.tar.gz
gnu: Add ghc-integer-logarithms.
* gnu/packages/haskell.scm (ghc-integer-logarithms): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/haskell.scm32
1 files changed, 32 insertions, 0 deletions
diff --git a/gnu/packages/haskell.scm b/gnu/packages/haskell.scm
index 34f630205b..03753c7e4b 100644
--- a/gnu/packages/haskell.scm
+++ b/gnu/packages/haskell.scm
@@ -4358,6 +4358,38 @@ functions for breaking or splitting on substrings and replacing all
occurrences of a substring (the first in case of overlaps) with another.")
(license license:bsd-3)))
+(define-public ghc-integer-logarithms
+ (package
+ (name "ghc-integer-logarithms")
+ (version "1.0.2")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "https://hackage.haskell.org/package/"
+ "integer-logarithms/integer-logarithms-"
+ version ".tar.gz"))
+ (sha256
+ (base32
+ "0w5mhak181zi6qr5h2zbcs9ymaqacisp9jwk99naz6s8zz5rq1ii"))))
+ (build-system haskell-build-system)
+ (inputs
+ `(("ghc-tasty" ,ghc-tasty)
+ ("ghc-tasty-smallcheck" ,ghc-tasty-smallcheck)
+ ("ghc-tasty-quickcheck" ,ghc-tasty-quickcheck)
+ ("ghc-tasty-hunit" ,ghc-tasty-hunit)
+ ("ghc-quickcheck" ,ghc-quickcheck)
+ ("ghc-smallcheck" ,ghc-smallcheck)))
+ (home-page "https://github.com/phadej/integer-logarithms")
+ (synopsis "Integer logarithms")
+ (description
+ "This package provides the following modules:
+@code{Math.NumberTheory.Logarithms} and
+@code{Math.NumberTheory.Powers.Integer} from the @code{arithmoi} package,
+@code{GHC.Integer.Logarithms.Compat} and
+@code{Math.NumberTheory.Power.Natural}, as well as some additional functions
+in migrated modules.")
+ (license license:expat)))
+
(define-public ghc-scientific
(package
(name "ghc-scientific")