summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorTimothy Sample <samplet@ngyro.com>2018-08-28 21:28:17 -0400
committerRicardo Wurmus <rekado@elephly.net>2018-10-01 12:12:10 +0200
commit95415545ab5b33e7e4d813b97d101c810b1ae338 (patch)
tree2b544f88828c99567091e51ef27c191e613c5a00 /gnu
parente95cc1087a13ab4c26244c31b7e6512c37042a5b (diff)
downloadpatches-95415545ab5b33e7e4d813b97d101c810b1ae338.tar
patches-95415545ab5b33e7e4d813b97d101c810b1ae338.tar.gz
gnu: ghc-foundation: Update to 0.0.21.
* gnu/packages/haskell.scm (ghc-foundation): Update to 0.0.21. [arguments]: Add a phase to create missing "Setup.hs" file.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/haskell.scm14
1 files changed, 12 insertions, 2 deletions
diff --git a/gnu/packages/haskell.scm b/gnu/packages/haskell.scm
index cc5dc152f6..860834d795 100644
--- a/gnu/packages/haskell.scm
+++ b/gnu/packages/haskell.scm
@@ -9233,7 +9233,7 @@ packages.")
(define-public ghc-foundation
(package
(name "ghc-foundation")
- (version "0.0.20")
+ (version "0.0.21")
(source
(origin
(method url-fetch)
@@ -9241,8 +9241,18 @@ packages.")
"foundation/foundation-" version ".tar.gz"))
(sha256
(base32
- "0bg4g0xf4pb2vmahnfp8c4f0a3v0av73lb5g8bwnp170khxfcsms"))))
+ "1q43y8wfj0wf9gdq2kzphwjwq6m5pvryy1lqgk954aq5z3ks1lsf"))))
(build-system haskell-build-system)
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'add-setup-script
+ (lambda _
+ ;; The usual "Setup.hs" script is missing from the source.
+ (with-output-to-file "Setup.hs"
+ (lambda ()
+ (format #t "import Distribution.Simple~%")
+ (format #t "main = defaultMain~%"))))))))
(inputs `(("ghc-basement" ,ghc-basement)))
(home-page "https://github.com/haskell-foundation/foundation")
(synopsis "Alternative prelude with batteries and no dependencies")