summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2018-02-12 20:33:53 +0100
committerRicardo Wurmus <rekado@elephly.net>2018-02-13 13:37:33 +0100
commit82674ed948d55d1d9782db05486147dc1db471bf (patch)
tree07769e757d40a28ad3ffe1972d9e7a959be3e59f /gnu
parent9dfc79b34c5f5a131e495aaf71c05dffe6e1b966 (diff)
downloadpatches-82674ed948d55d1d9782db05486147dc1db471bf.tar
patches-82674ed948d55d1d9782db05486147dc1db471bf.tar.gz
gnu: Add ghc-hashable-time.
* gnu/packages/haskell.scm (ghc-hashable-time): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/haskell.scm23
1 files changed, 23 insertions, 0 deletions
diff --git a/gnu/packages/haskell.scm b/gnu/packages/haskell.scm
index e0e61547d5..c253deb628 100644
--- a/gnu/packages/haskell.scm
+++ b/gnu/packages/haskell.scm
@@ -1806,6 +1806,29 @@ data structures. The package provides instances for basic types and a way to
combine hash values.")
(license license:bsd-3)))
+(define-public ghc-hashable-time
+ (package
+ (name "ghc-hashable-time")
+ (version "0.2.0.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append
+ "https://hackage.haskell.org/package/hashable-time/hashable-time-"
+ version
+ ".tar.gz"))
+ (sha256
+ (base32
+ "0k932nyd08l3xxbh2g3n76py2f4kd9yw4s5a065vjz0xp6wjnxdm"))))
+ (build-system haskell-build-system)
+ (inputs `(("ghc-hashable" ,ghc-hashable)))
+ (home-page "http://hackage.haskell.org/package/hashable-time")
+ (synopsis "Hashable instances for Data.Time")
+ (description
+ "This package provides @code{Hashable} instances for types in
+@code{Data.Time}.")
+ (license license:bsd-3)))
+
(define-public ghc-data-hash
(package
(name "ghc-data-hash")