summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2019-01-06 15:45:48 +0200
committerEfraim Flashner <efraim@flashner.co.il>2019-01-07 11:59:03 +0200
commite992d56669aac6e4e5a2c46d27902a882f3d1bc6 (patch)
tree0e1ffdd164015b1493c7a34cd9986f589856b60e /gnu
parent17f43346225d2d73ed366047e9d05059dbe59539 (diff)
downloadpatches-e992d56669aac6e4e5a2c46d27902a882f3d1bc6.tar
patches-e992d56669aac6e4e5a2c46d27902a882f3d1bc6.tar.gz
gnu: diffutils: Update to 3.7.
* gnu/packages/base.scm (diffutils): Update to 3.7. [source]: Remove patch. [native-inputs]: Add perl. * gnu/packages/commencement.scm (diffutils-boot0)[native-inputs]: Don't add perl. * gnu/packages/patches/diffutils-getopt.patch: Remove file. * gnu/local.mk (dist_patch_DATA): Remove it.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/local.mk1
-rw-r--r--gnu/packages/base.scm6
-rw-r--r--gnu/packages/commencement.scm1
-rw-r--r--gnu/packages/patches/diffutils-getopt.patch44
4 files changed, 4 insertions, 48 deletions
diff --git a/gnu/local.mk b/gnu/local.mk
index 7c970dc47c..d87d0b598d 100644
--- a/gnu/local.mk
+++ b/gnu/local.mk
@@ -657,7 +657,6 @@ dist_patch_DATA = \
%D%/packages/patches/deja-dup-use-ref-keyword-for-iter.patch \
%D%/packages/patches/dfu-programmer-fix-libusb.patch \
%D%/packages/patches/diffutils-gets-undeclared.patch \
- %D%/packages/patches/diffutils-getopt.patch \
%D%/packages/patches/docbook-xsl-nonrecursive-string-subst.patch \
%D%/packages/patches/doc++-include-directives.patch \
%D%/packages/patches/doc++-segfault-fix.patch \
diff --git a/gnu/packages/base.scm b/gnu/packages/base.scm
index d4d3317b98..aa85662a0c 100644
--- a/gnu/packages/base.scm
+++ b/gnu/packages/base.scm
@@ -245,16 +245,16 @@ differences.")
(define-public diffutils
(package
(name "diffutils")
- (version "3.6")
+ (version "3.7")
(source (origin
(method url-fetch)
(uri (string-append "mirror://gnu/diffutils/diffutils-"
version ".tar.xz"))
(sha256
(base32
- "1mivg0fy3a6fcn535ln8nkgfj6vxh5hsxxs5h6692wxmsjyyh8fn"))
- (patches (search-patches "diffutils-getopt.patch"))))
+ "09isrg0isjinv8c535nxsi1s86wfdfzml80dbw41dj9x3hiad9xk"))))
(build-system gnu-build-system)
+ (native-inputs `(("perl" ,perl)))
(synopsis "Comparing and merging files")
(description
"GNU Diffutils is a package containing tools for finding the
diff --git a/gnu/packages/commencement.scm b/gnu/packages/commencement.scm
index dc05e047d1..79246a0c5d 100644
--- a/gnu/packages/commencement.scm
+++ b/gnu/packages/commencement.scm
@@ -1430,6 +1430,7 @@ exec " gcc "/bin/" program
#:guile %bootstrap-guile)))
(package (inherit p)
(name "diffutils-boot0")
+ (native-inputs `())
(arguments `(#:tests? #f ; the test suite needs diffutils
,@(package-arguments p)))))))
diff --git a/gnu/packages/patches/diffutils-getopt.patch b/gnu/packages/patches/diffutils-getopt.patch
deleted file mode 100644
index 05c2504adf..0000000000
--- a/gnu/packages/patches/diffutils-getopt.patch
+++ /dev/null
@@ -1,44 +0,0 @@
-commit e3461d1c21a99bcef1b8826f710434e0ffb5adea
-Author: Paul Eggert <eggert@cs.ucla.edu>
-Date: Sun Jun 11 15:53:09 2017 -0700
-
- getopt-posix: port to glibc 2.25.90
-
- Problem reported by Daniel P. Berrange in:
- http://lists.gnu.org/archive/html/bug-gnulib/2017-06/msg00003.html
- * lib/getopt-pfx-core.h (_GETOPT_CORE_H):
- * lib/getopt-pfx-ext.h (_GETOPT_EXT_H):
- #undef if __GETOPT_PREFIX is defined.
-
-diff --git a/lib/getopt-pfx-core.h b/lib/getopt-pfx-core.h
-index 155c11612..6ad0da683 100644
---- a/lib/getopt-pfx-core.h
-+++ b/lib/getopt-pfx-core.h
-@@ -47,6 +47,11 @@
- # define opterr __GETOPT_ID (opterr)
- # define optind __GETOPT_ID (optind)
- # define optopt __GETOPT_ID (optopt)
-+
-+/* The system's getopt.h may have already included getopt-core.h to
-+ declare the unprefixed identifiers. Undef _GETOPT_CORE_H so that
-+ getopt-core.h declares them with prefixes. */
-+# undef _GETOPT_CORE_H
- #endif
-
- #include <getopt-core.h>
-diff --git a/lib/getopt-pfx-ext.h b/lib/getopt-pfx-ext.h
-index d960bb34e..c5ac52202 100644
---- a/lib/getopt-pfx-ext.h
-+++ b/lib/getopt-pfx-ext.h
-@@ -45,6 +45,11 @@
- # define getopt_long_only __GETOPT_ID (getopt_long_only)
- # define option __GETOPT_ID (option)
- # define _getopt_internal __GETOPT_ID (getopt_internal)
-+
-+/* The system's getopt.h may have already included getopt-ext.h to
-+ declare the unprefixed identifiers. Undef _GETOPT_EXT_H so that
-+ getopt-ext.h declares them with prefixes. */
-+# undef _GETOPT_EXT_H
- #endif
-
- /* Standalone applications get correct prototypes for getopt_long and