summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorRoel Janssen <roel@gnu.org>2016-04-08 10:48:58 +0200
committerLeo Famulari <leo@famulari.name>2016-04-12 14:55:10 -0400
commitec8c7e4734b9e28f08067301c42cda86d8ab3980 (patch)
treeb042f9cf3e59484fb51dd3eb9d64b1582191a297 /gnu
parentb4c400a75c9f432820146dfe24fcebdfbc276e4b (diff)
downloadpatches-ec8c7e4734b9e28f08067301c42cda86d8ab3980.tar
patches-ec8c7e4734b9e28f08067301c42cda86d8ab3980.tar.gz
gnu: Add r-pracma.
* gnu/packages/maths.scm (r-pracma): New variable. Signed-off-by: Leo Famulari <leo@famulari.name>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/maths.scm20
1 files changed, 20 insertions, 0 deletions
diff --git a/gnu/packages/maths.scm b/gnu/packages/maths.scm
index 6f61a637a0..a673a55eaa 100644
--- a/gnu/packages/maths.scm
+++ b/gnu/packages/maths.scm
@@ -10,6 +10,7 @@
;;; Copyright © 2015 Mark H Weaver <mhw@netris.org>
;;; Copyright © 2015, 2016 Efraim Flashner <efraim@flashner.co.il>
;;; Copyright © 2015 Fabian Harfert <fhmgufs@web.de>
+;;; Copyright © 2016 Roel Janssen <roel@gnu.org>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -37,6 +38,7 @@
#:use-module (guix build utils)
#:use-module (guix build-system cmake)
#:use-module (guix build-system gnu)
+ #:use-module (guix build-system r)
#:use-module (gnu packages algebra)
#:use-module (gnu packages bison)
#:use-module (gnu packages boost)
@@ -931,6 +933,24 @@ sparse system of linear equations A x = b using Guassian elimination.")
(inputs
(alist-delete "pt-scotch" (package-inputs mumps-openmpi)))))
+(define-public r-pracma
+ (package
+ (name "r-pracma")
+ (version "1.8.8")
+ (source (origin
+ (method url-fetch)
+ (uri (cran-uri "pracma" version))
+ (sha256
+ (base32 "0ans9l5rrb7a38gyi4qx4258sd5r5668vyrk02yzjpg9k3h8l165"))))
+ (build-system r-build-system)
+ (home-page "http://cran.r-project.org/web/packages/pracma")
+ (synopsis "Practical numerical math functions")
+ (description "This package provides functions for numerical analysis and
+linear algebra, numerical optimization, differential equations, plus some
+special functions. It uses Matlab function names where appropriate to simplify
+porting.")
+ (license license:gpl3+)))
+
(define-public superlu
(package
(name "superlu")