summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorVagrant Cascadian <vagrant@debian.org>2018-08-28 14:50:39 -0700
committerLeo Famulari <leo@famulari.name>2018-08-29 14:52:56 -0400
commitb4c698c8c99952fef0c9aa8c53c36631d84b5ef7 (patch)
tree412e1ac14f8bd78c1ef269656f8d37541a8bfd18 /gnu
parent4f9355c3606ecbe83dce78e6d01fa974d912bd4a (diff)
downloadpatches-b4c698c8c99952fef0c9aa8c53c36631d84b5ef7.tar
patches-b4c698c8c99952fef0c9aa8c53c36631d84b5ef7.tar.gz
gnu: python-trezor: Update to 0.10.2.
* gnu/packages/finance.scm (python-trezor): Update to 0.10.2. [arguments]: Replace check with tests that do not require hardware device. [propagated-inputs]: Add python-click, python-libusb1, python-pyblake2 and python-typing. [native-inputs]: Add python-mock and python-pytest. Signed-off-by: Leo Famulari <leo@famulari.name>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/finance.scm25
1 files changed, 20 insertions, 5 deletions
diff --git a/gnu/packages/finance.scm b/gnu/packages/finance.scm
index 7aeaffcc5d..28bfb28f49 100644
--- a/gnu/packages/finance.scm
+++ b/gnu/packages/finance.scm
@@ -664,23 +664,38 @@ Ledger Blue/Nano S.")
(define-public python-trezor
(package
(name "python-trezor")
- (version "0.7.16")
+ (version "0.10.2")
(source
(origin
(method url-fetch)
(uri (pypi-uri "trezor" version))
(sha256
(base32
- "055kii56wgwadl5z911s59ya2fnsqzk3n5i19s2hb9sv2by6knvb"))))
+ "138k6zsqqpb46k3rcpyslm9q7yq5i6k4myvr9n425jnkadf4vfjd"))))
(build-system python-build-system)
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ ;; Default tests run device-specific tests which fail, only run specific tests.
+ (replace 'check
+ (lambda* (#:key inputs outputs #:allow-other-keys)
+ (invoke "python" "-m" "pytest" "--pyarg" "trezorlib.tests.unit_tests")
+ (invoke "python" "-m" "pytest" "-m" "slow_cosi" "--pyarg" "trezorlib.tests.unit_tests")
+ )))))
(propagated-inputs
- `(("python-ecdsa" ,python-ecdsa)
+ `(("python-click" ,python-click)
+ ("python-ecdsa" ,python-ecdsa)
("python-hidapi" ,python-hidapi)
+ ("python-libusb1" ,python-libusb1)
("python-mnemonic" ,python-mnemonic)
("python-protobuf" ,python-protobuf)
- ("python-requests" ,python-requests)))
+ ("python-pyblake2" ,python-pyblake2)
+ ("python-requests" ,python-requests)
+ ("python-typing" ,python-typing)))
(native-inputs
- `(("python-pyqt" ,python-pyqt))) ; Tests
+ `(("python-mock" ,python-mock) ; Tests
+ ("python-pyqt" ,python-pyqt) ; Tests
+ ("python-pytest" ,python-pytest))) ; Tests
(home-page "https://github.com/trezor/python-trezor")
(synopsis "Python library for communicating with TREZOR Hardware Wallet")
(description "@code{trezor} is a Python library for communicating with