summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorRicardo Wurmus <ricardo.wurmus@mdc-berlin.de>2016-03-30 12:23:51 +0200
committerRicardo Wurmus <ricardo.wurmus@mdc-berlin.de>2016-04-11 15:11:15 +0200
commita3e90287705b931f03c441c1736f16f51e20b882 (patch)
treec00816adb95a8f6b93961370fbde0d7d804b562a /gnu
parentae2462f7dd8abfdd6e5a603c55443ec5246936f0 (diff)
downloadpatches-a3e90287705b931f03c441c1736f16f51e20b882.tar
patches-a3e90287705b931f03c441c1736f16f51e20b882.tar.gz
gnu: Add r-bsgenome-mmusculus-ucsc-mm9.
* gnu/packages/bioinformatics.scm (r-bsgenome-mmusculus-ucsc-mm9): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/bioinformatics.scm31
1 files changed, 31 insertions, 0 deletions
diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index 4ea7534568..15a367da3b 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -4800,6 +4800,37 @@ Stephens (1990).")
by UCSC (hg19, February 2009) and stored in Biostrings objects.")
(license license:artistic2.0)))
+(define-public r-bsgenome-mmusculus-ucsc-mm9
+ (package
+ (name "r-bsgenome-mmusculus-ucsc-mm9")
+ (version "1.4.0")
+ (source (origin
+ (method url-fetch)
+ ;; We cannot use bioconductor-uri here because this tarball is
+ ;; located under "data/annotation/" instead of "bioc/".
+ (uri (string-append "http://www.bioconductor.org/packages/"
+ "release/data/annotation/src/contrib/"
+ "BSgenome.Mmusculus.UCSC.mm9_"
+ version ".tar.gz"))
+ (sha256
+ (base32
+ "1birqw30g2azimxpnjfzmkphan7x131yy8b9h85lfz5fjdg7841i"))))
+ (properties
+ `((upstream-name . "BSgenome.Mmusculus.UCSC.mm9")))
+ (build-system r-build-system)
+ ;; As this package provides little more than a very large data file it
+ ;; doesn't make sense to build substitutes.
+ (arguments `(#:substitutable? #f))
+ (propagated-inputs
+ `(("r-bsgenome" ,r-bsgenome)))
+ (home-page
+ "http://www.bioconductor.org/packages/BSgenome.Mmusculus.UCSC.mm9/")
+ (synopsis "Full genome sequences for Mouse")
+ (description
+ "This package provides full genome sequences for Mus musculus (Mouse) as
+provided by UCSC (mm9, July 2007) and stored in Biostrings objects.")
+ (license license:artistic2.0)))
+
(define-public r-motifrg
(package
(name "r-motifrg")