summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2017-07-10 22:39:54 +0200
committerRicardo Wurmus <rekado@elephly.net>2017-07-17 14:00:14 +0200
commit7709d4d86a62c7b917de288bcfb72a5a0c8ad3fc (patch)
treedd3924de34a10ea4d62e21b3d71a0f3a042ffeb5 /gnu
parentdcc8af4a64f071271f7fc4c8ba32a1875c2344d0 (diff)
downloadpatches-7709d4d86a62c7b917de288bcfb72a5a0c8ad3fc.tar
patches-7709d4d86a62c7b917de288bcfb72a5a0c8ad3fc.tar.gz
gnu: Add texlive-latex-capt-of.
* gnu/packages/tex.scm (texlive-latex-capt-of): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/tex.scm33
1 files changed, 33 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 5040433784..3ac3c5bf8c 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -1838,6 +1838,39 @@ recent classes such as powerdot or beamer, both of which are tuned to
21st-century presentation styles.")
(license license:lppl1.2+)))
+(define-public texlive-latex-capt-of
+ (package
+ (name "texlive-latex-capt-of")
+ (version (number->string %texlive-revision))
+ (source (origin
+ (method svn-fetch)
+ (uri (svn-reference
+ (url (string-append "svn://www.tug.org/texlive/tags/"
+ %texlive-tag "/Master/texmf-dist/"
+ "/tex/latex/capt-of"))
+ (revision %texlive-revision)))
+ (file-name (string-append name "-" version "-checkout"))
+ (sha256
+ (base32
+ "1y2s50f6lz0jx2748lj3iy56hrpcczgnbzmvphxv7aqndyyamd4x"))))
+ (build-system trivial-build-system)
+ (arguments
+ `(#:modules ((guix build utils))
+ #:builder
+ (begin
+ (use-modules (guix build utils))
+ (let ((target (string-append (assoc-ref %outputs "out")
+ "/share/texmf-dist/tex/latex/capt-of")))
+ (mkdir-p target)
+ (copy-recursively (assoc-ref %build-inputs "source") target)
+ #t))))
+ (home-page "http://www.ctan.org/pkg/capt-of")
+ (synopsis "Captions on more than floats")
+ (description
+ "This package defines a command @code{\\captionof} for putting a caption
+to something that's not a float.")
+ (license license:lppl)))
+
(define-public texlive-latex-fncychap
(package
(name "texlive-latex-fncychap")