summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorRicardo Wurmus <ricardo.wurmus@mdc-berlin.de>2017-10-05 11:56:46 +0200
committerRicardo Wurmus <rekado@elephly.net>2017-10-05 12:04:32 +0200
commit67a08f1809c5a67dfb862ccdc3dc4e13ae35dcbf (patch)
treeadacfc63973d7b1da6d40579ddda551af57ae702 /gnu
parenteaa1db1de615bc0ed51b295a0a191ce2c816ee7e (diff)
downloadpatches-67a08f1809c5a67dfb862ccdc3dc4e13ae35dcbf.tar
patches-67a08f1809c5a67dfb862ccdc3dc4e13ae35dcbf.tar.gz
gnu: Add python-numpy-next.
* gnu/packages/python.scm (python-numpy-next, python2-numpy-next): New variables.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/python.scm22
1 files changed, 22 insertions, 0 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index 271f147b43..594dd38e42 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -3717,6 +3717,8 @@ producing implementations of dynamic languages, emphasizing a clean separation
between language specification and implementation aspects.")
(license license:expat)))
+;; NOTE: when upgrading numpy please make sure that python-pandas and
+;; python-scipy still build, as these three packages are often used together.
(define-public python-numpy
(package
(name "python-numpy")
@@ -3793,6 +3795,26 @@ capabilities.")
(define-public python2-numpy
(package-with-python2 python-numpy))
+(define-public python-numpy-next
+ (package (inherit python-numpy)
+ (name "python-numpy-next")
+ (version "1.13.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "numpy" version ".zip"))
+ (sha256
+ (base32
+ "1fsgkhh1vdkhmlz8vmdgxnj9n9yaanckxxzz9s0b4p08fqvjic69"))))
+ (native-inputs
+ `(("unzip" ,unzip)
+ ("python-cython" ,python-cython)
+ ("python-nose" ,python-nose)
+ ("gfortran" ,gfortran)))))
+
+(define-public python2-numpy-next
+ (package-with-python2 python-numpy-next))
+
(define-public python-munch
(package
(name "python-munch")